Bug 151672 - find-next (f3) does not work after find (ctrl-f)
find-next (f3) does not work after find (ctrl-f)
Status: RESOLVED FIXED
Product: editor
Classification: Unclassified
Component: Search
6.x
Other Linux
: P3 with 3 votes (vote)
: 6.x
Assigned To: Sergey Petrov
issues@editor
: USABILITY
: 153476 154469 159184 160356 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-29 08:49 UTC by moojix
Modified: 2009-05-07 12:51 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description moojix 2008-10-29 08:49:21 UTC
find-next (f3) does not work after find (ctrl-f)

flow:
ctrl-F: enter a search word
F3 (search next) -> does not work

current editor window is not focused
(workaround: focus current editor window with a mouse click, then F3 works)
Comment 1 Jan Becicka 2008-10-29 11:00:22 UTC
Please evaluate
Comment 2 Vitezslav Stejskal 2008-10-29 13:17:42 UTC
Currently only Enter and Shift+Enter trigger the find next/previous search when in the search bar. We should also bind
F3 and Shift+F3 to these actions. But the problem is far less serious than P2.
Comment 3 Marian Mirilovic 2008-11-04 12:38:52 UTC
mentioned on CA survey ... Mila/Vita could we add this into Nb 6.5 Patch 1  ?
Comment 4 Petr Dvorak 2008-11-20 12:22:41 UTC
*** Issue 153476 has been marked as a duplicate of this issue. ***
Comment 5 Alexei Mokeev 2009-04-15 13:48:28 UTC
*** Issue 160356 has been marked as a duplicate of this issue. ***
Comment 6 Alexei Mokeev 2009-04-15 13:53:29 UTC
*** Issue 159184 has been marked as a duplicate of this issue. ***
Comment 7 Sergey Petrov 2009-04-16 12:08:40 UTC
for reference:
there are two actions: 
org.netbeans.editor.ActionFactory$FindNextAction is used in editor, use already entered search text to search and have
default F3
org.netbeans.modules.editor.impl.SearchBar$IncrementalSearchForwardAction is used to open search bar if not opened,
select search text in serach bar, and search next if searchbar is opened, it's binded to ctrl-f shortcut by default.
Comment 8 Sergey Petrov 2009-04-17 10:13:54 UTC
http://hg.netbeans.org/core-main/rev/7339a16c2363 fixed in core main, need some time to propagate
Comment 9 Quality Engineering 2009-04-18 07:19:55 UTC
Integrated into 'main-golden', will be available in build *200904180201* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/7339a16c2363
User: sergeyp@netbeans.org
Log: fix #151672 - search keystrokes from editor should work in search bar now
Comment 10 Quality Engineering 2009-04-20 20:20:03 UTC
Integrated into 'main-golden', will be available in build *200904201507* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/7339a16c2363
User: sergeyp@netbeans.org
Log: fix #151672 - search keystrokes from editor should work in search bar now
Comment 11 Sergey Petrov 2009-05-07 12:51:08 UTC
*** Issue 154469 has been marked as a duplicate of this issue. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo