Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 151666 - Request to have an option to specify terminal software
Request to have an option to specify terminal software
Status: RESOLVED WONTFIX
Product: cnd
Classification: Unclassified
Component: -- Other --
6.x
All All
: P3 (vote)
: TBD
Assigned To: issues@cnd
issues@cnd
JA_COMMUNITY
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-29 07:53 UTC by Keiichi Oono
Modified: 2008-10-29 16:05 UTC (History)
0 users

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Keiichi Oono 2008-10-29 07:53:02 UTC
Would you implement an option to specify terminal software?
For example, I would like to use uxterm (/usr/X11R6/bin/uxterm) instead of xterm in my Mac OS X to display Japanese
characters in the terminal window. I think it's useful for users in Solaris/Linux boxes if terminal software can be
customized.

It would be nice if I can specify the full path (e.g. /usr/X11R6/bin/uxterm) on "Run" page in the Project Properties window.
Comment 1 _ gordonp 2008-10-29 16:05:42 UTC
This is actually much more difficult than it sounds and might easily break IDE usage.

The problem isn't in specifying a new term, but in getting the command line correct
so it works as expected with the IDE. If we allow users to add their own terminal
emulators then if they get the options wrong it would break execution and debugging.
The options string contains embedded variable information which the user doesn't even
know. In many cases the IDE wouldn't even be able to tell something was wrong...

Here is part of the option string for gnome-terminal, which has a slightly
more complicated setup than xterm (taken from .../api/runprofiles/RunProfile.java
in cnd.makeproject):

    String opts = "--disable-factory --hide-menubar " + "--title=\"{1} {3}\" " + // NOI18N
            "-x \"" + dorun + "\" -p \"" + getString("LBL_RunPrompt") + "\" " + // NOI18N
            "-f \"{0}\" {1} {2}"; // NOI18N

(It would be easy for the user to get this wrong, especially the quoting :-)

I'm closing this enh as WONTFIX. It would be *significantly* easier to add uxterm support
than to add generic term add capabilities (choices don't get added to the menu unless they
are actually on the machine in question, so it wouldn't show in most menus). However, I
googled uxterm and found out its a script. Its likely the script would incorrectly pass
some of the options to xterm (some of the options have embedded spaces).

None the less, it could be explored if desired (as could rxvt) ...


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo