Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 151576 - NullPointerException at org.netbeans.modules.masterfs.filebasedfs.fileobjects.LockForFile.registerLock
NullPointerException at org.netbeans.modules.masterfs.filebasedfs.fileobjects...
Status: VERIFIED FIXED
Product: platform
Classification: Unclassified
Component: Filesystems
6.x
All All
: P3 (vote)
: 6.x
Assigned To: Jiri Skrivanek
issues@platform
http://statistics.netbeans.org/except...
65fixes2-verified EXCEPTIONS_REPORT
:
: 154746 156598 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-28 11:42 UTC by gtg
Modified: 2009-02-19 22:53 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (1.96 KB, text/plain)
2008-10-28 11:42 UTC, gtg
Details

Note You need to log in before you can comment on or make changes to this bug.
Description gtg 2008-10-28 11:42:27 UTC
Build: NetBeans IDE Dev (Build 200810220201)
VM: Java HotSpot(TM) 64-Bit Server VM, 10.0-b23, Java(TM) SE Runtime Environment, 1.6.0_07-b06
OS: Linux, 2.6.25.18-0.2-default, amd64

Stacktrace: 
java.lang.NullPointerException
        at org.netbeans.modules.masterfs.filebasedfs.fileobjects.LockForFile.registerLock(LockForFile.java:108)
        at org.netbeans.modules.masterfs.filebasedfs.fileobjects.LockForFile.tryLock(LockForFile.java:96)
        at org.netbeans.modules.masterfs.filebasedfs.fileobjects.FileObj.lock(FileObj.java:277)
        at org.netbeans.modules.versioning.system.cvss.CvsVersioningSystem.writeCvsIgnoreEntries(CvsVersioningSystem.java:701)
        at org.netbeans.modules.versioning.system.cvss.CvsVersioningSystem.addToCvsIgnore(CvsVersioningSystem.java:653)
        at org.netbeans.modules.versioning.system.cvss.CvsVersioningSystem.setIgnored(CvsVersioningSystem.java:625)
Comment 1 gtg 2008-10-28 11:42:32 UTC
Created attachment 72760 [details]
stacktrace
Comment 2 Jiri Skrivanek 2008-10-29 10:44:06 UTC
Fixed.
Comment 3 Quality Engineering 2008-10-30 04:58:40 UTC
Integrated into 'main-golden', will be available in build *200810300201* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/0bd7a531f3a7
User: Jiri Skrivanek <jskrivanek@netbeans.org>
Log: #151576 - Check for null although it should not happen.
Comment 4 Jiri Skrivanek 2008-12-05 20:35:24 UTC
*** Issue 154746 has been marked as a duplicate of this issue. ***
Comment 5 stefan79 2008-12-17 11:01:24 UTC
The exception occured again (NB 6.5Patch1 - Build 200811100001).

java.lang.NullPointerException
	at org.netbeans.modules.masterfs.filebasedfs.fileobjects.LockForFile.registerLock(LockForFile.java:108)
	at org.netbeans.modules.masterfs.filebasedfs.fileobjects.LockForFile.tryLock(LockForFile.java:96)
	at org.netbeans.modules.masterfs.filebasedfs.fileobjects.FileObj.lock(FileObj.java:277)
	at org.netbeans.modules.versioning.system.cvss.CvsVersioningSystem.writeCvsIgnoreEntries(CvsVersioningSystem.java:701)
	at org.netbeans.modules.versioning.system.cvss.CvsVersioningSystem.addToCvsIgnore(CvsVersioningSystem.java:653)
	at org.netbeans.modules.versioning.system.cvss.CvsVersioningSystem.setIgnored(CvsVersioningSystem.java:625)
	at org.netbeans.modules.versioning.system.cvss.CvsVersioningSystem.isIgnored(CvsVersioningSystem.java:334)
	at org.netbeans.modules.versioning.system.cvss.FileStatusCache.createMissingEntryFileInformation(FileStatusCache.java:647)
	at org.netbeans.modules.versioning.system.cvss.FileStatusCache.createFileInformation(FileStatusCache.java:537)
	at org.netbeans.modules.versioning.system.cvss.FileStatusCache.scanFolder(FileStatusCache.java:478)
	at org.netbeans.modules.versioning.system.cvss.FileStatusCache.getScannedFiles(FileStatusCache.java:445)
	at org.netbeans.modules.versioning.system.cvss.FileStatusCache.refreshNow(FileStatusCache.java:256)
	at org.netbeans.modules.versioning.system.cvss.FileStatusCache.refresh(FileStatusCache.java:324)
	at org.netbeans.modules.versioning.system.cvss.FilesystemHandler.fileCreatedImpl(FilesystemHandler.java:223)
	at org.netbeans.modules.versioning.system.cvss.FilesystemHandler.access$100(FilesystemHandler.java:60)
	at org.netbeans.modules.versioning.system.cvss.FilesystemHandler$2.run(FilesystemHandler.java:204)
Comment 6 Jiri Skrivanek 2008-12-17 17:29:15 UTC
It is fixed in NetBeans 7.0 Milestone 1.
Comment 7 Lukas Hasik 2008-12-18 08:44:37 UTC
I'm marking as candidate for patch2 of NB6.5. I'm marking as verified as well however I' checked just the code as there
are no steps to reproduce
Comment 8 pgebauer 2008-12-19 12:00:48 UTC
The fix has been ported into the release65_fixes repository.

http://hg.netbeans.org/release65_fixes/rev/b5ddd8a0afed

Comment 9 Jiri Skrivanek 2009-01-12 11:58:21 UTC
*** Issue 156598 has been marked as a duplicate of this issue. ***
Comment 10 Lukas Hasik 2009-01-16 11:57:06 UTC
the fix should be available in patch2 for 65 soon


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo