Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 151538 - mobility cluster needs org.netbeans.modules.apisupport.project from apisupport cluster
mobility cluster needs org.netbeans.modules.apisupport.project from apisuppor...
Status: RESOLVED FIXED
Product: javame
Classification: Unclassified
Component: Build System
6.x
PC Linux
: P3 (vote)
: 6.x
Assigned To: Petr Suchomel
issues@mobility
: ARCH
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-27 23:00 UTC by fordfrog
Modified: 2009-09-17 00:28 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description fordfrog 2008-10-27 23:00:27 UTC
Though dependency on apisupport cluster is not specified in cluster.properties for mobility cluster, mobility cluster
needs org.netbeans.modules.apisupport.project from apisupport cluster and so it depends on apisupport cluster and cannot
be built without it.


Used sources: http://download.netbeans.org/netbeans/6.5/rc/zip/netbeans-6.5rc1-200810171318-src.zip


Build command (from Gentoo ebuild):

eant '-Dstop.when.broken.modules=true' '-Dbuild.compiler.deprecation=false'
'-Dnb.clusters.list=nb.cluster.platform,nb.cluster.nb,nb.cluster.groovy,nb.cluster.gsf,nb.cluster.harness,nb.cluster.ide,nb.cluster.j2ee,nb.cluster.java,nb.cluster.mobility,nb.cluster.websvccommon'
'-f' 'nbbuild/build.xml' 'build-nozip'


Error output:

build-init:
  [nbmerge] Failed to build target: all-vmd.componentssupport

BUILD FAILED
/var/tmp/portage/dev-util/netbeans-6.5_rc1/work/nbbuild/build.xml:713: The following error occurred while executing this
line:
/var/tmp/portage/dev-util/netbeans-6.5_rc1/work/nbbuild/build.xml:708: The following error occurred while executing this
line:
/var/tmp/portage/dev-util/netbeans-6.5_rc1/work/nbbuild/build.xml:754: The following error occurred while executing this
line:
/var/tmp/portage/dev-util/netbeans-6.5_rc1/work/nbbuild/templates/projectized.xml:87: No dependent module
org.netbeans.modules.apisupport.project
Comment 1 Petr Suchomel 2008-11-12 09:56:50 UTC
Jesse, could you comment on this? Also decreasing to P4 as it is not runtime issue
Comment 2 Jesse Glick 2008-11-13 00:45:59 UTC
Making mobility dep on apisupport seems undesirable, and making a new cluster just for this one module seems wrong.
Probably the first option is the only viable solution: fix the cluster dependencies.

In general, using the cluster as a unit of work for the build is problematic. See similar issue #145198.

Not a runtime problem, but mistakes in our build system delay the work of packagers, and that hurts adoption of our product.
Comment 3 Petr Suchomel 2008-11-16 20:14:32 UTC
When do you expect we can fix this Jesse?
Comment 4 Jesse Glick 2008-11-17 17:42:12 UTC
What do you mean? You can fix it any day you like. It's a one-line change in cluster.properties.
Comment 5 Jesse Glick 2009-01-06 00:49:30 UTC
Maybe fixed in 05dc74434a40?
Comment 6 Petr Suchomel 2009-09-04 13:35:18 UTC

*** This issue has been marked as a duplicate of 158064 ***
Comment 7 Jesse Glick 2009-09-17 00:28:19 UTC
No, that is about the dep on the enterprise cluster. This is a dep on apisupport.
Comment 8 Jesse Glick 2009-09-17 00:28:45 UTC
Again, I believe fixed in 05dc74434a40.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo