Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 151537 - [65cat] Infinite Loop in exception reporter (was: When Compilation Fails)
[65cat] Infinite Loop in exception reporter (was: When Compilation Fails)
Status: VERIFIED FIXED
Product: ide
Classification: Unclassified
Component: Logger
6.x
PC Windows XP
: P2 (vote)
: 6.x
Assigned To: mslama
logger-issues@ide
65fixes1-verified
:
: 152446 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-27 22:53 UTC by esmithbss
Modified: 2009-02-19 22:40 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
Zipped Project (664.78 KB, application/x-compressed)
2008-10-27 22:54 UTC, esmithbss
Details
IDE Log File (89.38 KB, text/plain)
2008-10-27 22:55 UTC, esmithbss
Details
Gestures File (1.18 MB, text/plain)
2008-10-27 22:55 UTC, esmithbss
Details
Metrics File (173.38 KB, text/plain)
2008-10-27 22:55 UTC, esmithbss
Details

Note You need to log in before you can comment on or make changes to this bug.
Description esmithbss 2008-10-27 22:53:42 UTC
[ BUILD # : 200810271401 ]
[ JDK VERSION : 1.6.0_07 ]

I have a very simple program (attached) that is in the middle of
being developed.  During development, I tried to do a "Clean and
Build" which failed due to a syntax error.

When I commented out the error and tried to do a Build, the system
generated a SAXParserException.  By Clicking on the "Review" button,
I ended up with another SAXParserException.  Each successive click on
the "Review" button resulted in another SAX Parser Exception until I
cancelled out.

Upon cancelling out, I lost all exception information and was unable
to determine what had actually caused the problem in the first place.

I'm marking this P1 due to the loss of information (No idea what the
exception was) and the misleading nature of how to solve it (the
obvious choice to "Review" the exception generates another
exception).
Comment 1 esmithbss 2008-10-27 22:54:17 UTC
Created attachment 72722 [details]
Zipped Project
Comment 2 esmithbss 2008-10-27 22:55:11 UTC
Created attachment 72723 [details]
IDE Log File
Comment 3 esmithbss 2008-10-27 22:55:31 UTC
Created attachment 72724 [details]
Gestures File
Comment 4 esmithbss 2008-10-27 22:55:47 UTC
Created attachment 72725 [details]
Metrics File
Comment 5 mslama 2008-10-29 13:45:01 UTC
Our html files do not follow <!DOCTYPE html
PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN"
"http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">

Umbrella issue is #149082. I will fix /org/netbeans/modules/uihandler/UnknownHostException.html now. Not P1 even if it
is confusing.
Comment 6 mslama 2008-10-29 17:04:58 UTC
core-main #4eb1ba2cf702

DOCTYPE is commented out because parser tries to get DTD from Internet. So we must either comment out DOCTYPE or add
custom EntityResolver. html document is anyway validated and follows XHTML 1.0 Transitional.
Comment 7 Quality Engineering 2008-10-30 05:00:00 UTC
Integrated into 'main-golden', will be available in build *200810300201* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/4eb1ba2cf702
User: Marek Slama <mslama@netbeans.org>
Log: #151537: Fix html document.
Comment 8 mslama 2008-10-30 14:21:48 UTC
core-main #43eebe709510

Added EntityResolver to avoid resolving DTD URL - it results in UnknownHostException when XHTML document is parsed in
offline mode. DOCTYPE header is added to html document.
Comment 9 mslama 2008-10-31 13:02:30 UTC
Last patch reapplied.
core-main #0dd9cb0b20bd

It was reverted to fix merge conflict #720fe00dcf4b
Comment 10 Quality Engineering 2008-10-31 16:28:10 UTC
Integrated into 'main-golden', will be available in build *200810311401* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/43eebe709510
User: Marek Slama <mslama@netbeans.org>
Log: #151537: Fix html document - add EntityResolver, add DOCTYPE XHTML.
Comment 11 Quality Engineering 2008-11-01 05:11:15 UTC
Integrated into 'main-golden', will be available in build *200811010201* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/0dd9cb0b20bd
User: Marek Slama <mslama@netbeans.org>
Log: #151537: Fix html document - add EntityResolver, add DOCTYPE XHTML - patch reapplied due to merge conflict.
Comment 12 mslama 2008-11-06 10:28:57 UTC
Lukas it would be good to put this into next patch. It can cause that user is unable to start IDE. See issue #152446.
Comment 13 mslama 2008-11-06 10:30:19 UTC
*** Issue 152446 has been marked as a duplicate of this issue. ***
Comment 14 Lukas Hasik 2008-11-06 14:47:27 UTC
agree, it should go to patch. Is there a way how to reproduce it? I cannot reproduce it with the original steps. I'll
look at it later more precisely.

Justification for P2 - this can cause infinite loop and therefore user can lost a data
Comment 15 rbalada 2008-11-14 10:11:41 UTC
Please verify this issue so it can be included in NetBeans 6.5 Patch1
Comment 16 Lukas Hasik 2008-11-20 15:40:10 UTC
v
Comment 17 pslechta 2008-11-21 15:23:31 UTC
The fix was ported into release65_fixes repository.

http://hg.netbeans.org/release65_fixes/rev/4fb38ec9caaa
http://hg.netbeans.org/release65_fixes/rev/83bbb58510a2
Comment 18 Lukas Hasik 2008-12-02 14:56:22 UTC
unable to reproduce with the patch 1 for 6.5 -
http://bits.netbeans.org/netbeans/6.5/fixes/2008-11-27_17-23-59/uc/catalog.xml.gz


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo