Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 151464 - Cannot add breakpoint in a tag file
Cannot add breakpoint in a tag file
Status: VERIFIED FIXED
Product: javaee
Classification: Unclassified
Component: Debugger
6.x
All Linux
: P3 (vote)
: 7.0
Assigned To: Martin Entlicher
issues@javaee
69patch1-verified
: SIMPLEFIX
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-27 13:44 UTC by martin_zmrhal
Modified: 2010-07-09 13:58 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description martin_zmrhal 2008-10-27 13:44:46 UTC
In a tag file (new Web Application -> Web Pages -> New -> Tag File) it is not possible to add breakpoints by clicking on
the left side of the editor window. However there is a workaround via Ctrl+F8.

Product Version: NetBeans IDE 6.5 RC2 (Build 200810270001)
Java: 1.6.0_10-rc2; Java HotSpot(TM) Client VM 11.0-b15
System: Linux version 2.6.24-21-generic running on i386; UTF-8; en_US (nb)
Comment 1 Jindrich Sedek 2009-05-07 13:34:53 UTC
This issue is more a bug than an enhancement - debugging of tag files works well - IDE stops on break point in tagfiles 
correctly, but the feature is fully hidden by this bug
Comment 2 Petr Jiricka 2009-07-24 16:06:05 UTC
Martine, could you please help? Thanks.
Comment 3 Martin Entlicher 2010-05-18 12:04:51 UTC
Reproduced.
It does not work, because ToggleBreakpointAction is not defined in a gutter for tag files.
Comment 4 Martin Entlicher 2010-05-18 12:36:58 UTC
Fixed in changeset:   171397:8a9957a33305
http://hg.netbeans.org/main/rev/8a9957a33305
Comment 5 Martin Entlicher 2010-05-18 22:25:26 UTC
It did not get into release69.
Comment 6 rbalada 2010-06-16 08:52:37 UTC
Please verify bugfix for this bug, so it can be included in release691 repository.

Thanks,
-R
Comment 7 rbalada 2010-06-21 16:01:10 UTC
Please verify bugfix for this bug, so it can be integrated into release691 repository.

Thanks,
-R
Comment 8 rbalada 2010-06-25 06:16:24 UTC
Last chance for inclusion in release691.

Please verify within 4 hours from now, since I have got limited time to transplant remaining bugfixes into release691 repository. June 25, 1 PM Prague time is my deadline. After that time, please do also the transplant/porting work if you want to include it.

Thank you for understanding,
-R
Comment 9 Martin Entlicher 2010-06-25 06:42:43 UTC
The fix is trivial and does not break anything - verified.
Comment 10 rbalada 2010-06-25 08:59:31 UTC
main #8a9957a33305 transplanted to release691 #1fc3a32886c0
Comment 11 Jan Horvath 2010-07-09 13:58:20 UTC
verified in NetBeans IDE 6.9.1 Dev (Build 201007072301)


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo