Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 151422 - com.sun.tools.javac.util.FatalError: Fatal Error: Unable to find method initCause
com.sun.tools.javac.util.FatalError: Fatal Error: Unable to find method initC...
Status: CLOSED FIXED
Product: java
Classification: Unclassified
Component: Compiler
6.x
All All
: P2 (vote)
: 6.x
Assigned To: Dusan Balek
issues@java
http://statistics.netbeans.org/except...
EXCEPTIONS_REPORT
:
: 141521 152406 155012 (view as bug list)
Depends on:
Blocks: 152191
  Show dependency treegraph
 
Reported: 2008-10-27 09:30 UTC by Marian Mirilovic
Modified: 2010-04-22 10:34 UTC (History)
13 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Marian Mirilovic 2008-10-27 09:30:33 UTC
16 duplicate so far ... only on Vista & XP

Build: NetBeans IDE 6.5 Beta (Build 200808111757)
VM: Java HotSpot(TM) Client VM, 1.5.0_13-119, Java(TM) 2 Runtime Environment, Standard Edition, 1.5.0_13-b05-237
OS: Mac OS X, 10.5.4, i386
User comments: 
STACKTRACE: (first 10 lines)
com.sun.tools.javac.util.FatalError: Fatal Error: Unable to find method initCause
        at com.sun.tools.javac.comp.Resolve.resolveInternalMethod(Resolve.java:1270)
        at com.sun.tools.javac.comp.Lower.lookupMethod(Lower.java:640)
        at com.sun.tools.javac.comp.Lower.makeCall(Lower.java:1655)
        at com.sun.tools.javac.comp.Lower.classDollarSymBody(Lower.java:1618)
        at com.sun.tools.javac.comp.Lower.classDollarSym(Lower.java:1517)
        at com.sun.tools.javac.comp.Lower.classOfType(Lower.java:1737)
        at com.sun.tools.javac.comp.Lower.classOf(Lower.java:1707)
        at com.sun.tools.javac.comp.Lower.visitSelect(Lower.java:3076)
        at com.sun.tools.javac.tree.JCTree$JCFieldAccess.accept(JCTree.java:1655)
        at com.sun.tools.javac.tree.TreeTranslator.translate(TreeTranslator.java:58)
Comment 1 Dusan Balek 2009-01-06 13:34:02 UTC
Seems like a source level is set to 1.5/1.4 while compiling against 1.4/1.3 or lower libraries.

Fixed.
changeset d454571df68f in main
details: http://hg.netbeans.org/main?cmd=changeset;node=d454571df68f
Comment 2 Dusan Balek 2009-01-06 13:52:47 UTC
*** Issue 152406 has been marked as a duplicate of this issue. ***
Comment 3 Dusan Balek 2009-01-06 14:00:13 UTC
*** Issue 155012 has been marked as a duplicate of this issue. ***
Comment 4 Quality Engineering 2009-01-07 05:37:50 UTC
Integrated into 'main-golden', will be available in build *200901070201* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/d454571df68f
User: Dusan Balek <dbalek@netbeans.org>
Log: Issue #151422: com.sun.tools.javac.util.FatalError: Fatal Error: Unable to find method initCause - fixed.
Comment 5 Marian Mirilovic 2009-01-13 08:09:06 UTC
haven't seen new report since fix was integrated - verified
Comment 6 Marian Mirilovic 2009-01-13 08:53:53 UTC
need to be integrated together with issue 143923
Comment 7 rbalada 2009-01-13 13:18:16 UTC
Petre,

during backport to release65_fixes please change logging level from warning to fine.
Comment 8 pgebauer 2009-01-14 23:31:35 UTC
The changeset d454571df68f changes the file JavacParser.java but the file JavacParser.java doesn't occur in the release65_fixes nor the release65 branch. It 
seems, the file has been merged into the trunk after the NetBeans IDE 6.5 release as a part of significant improvement. If so, the port to the release65_fixes 
branch could be non-trivial.
Comment 9 pgebauer 2009-01-15 09:58:32 UTC
The file JavacParser.java is part of the new java parsing API which was introduced after NetBeans 6.5 IDE release. This is a not suitable candidate for the 
patch.
Comment 10 pgebauer 2009-01-15 10:53:07 UTC
Removed from a patch after discussion with QA.
Comment 11 rosmord 2009-01-18 21:27:07 UTC
It occurs also on Mac OS X. I was working on a Jdk 1.4 project at that time.

Comment 12 Petr Hejl 2009-03-05 21:58:36 UTC
Looks like it's back again - present in 09/02/XX and 09/03/XX builds.
Comment 13 Dusan Balek 2009-03-12 11:49:39 UTC
Fixed.

changeset 4c07517dbd79 in main/nb-javac
details: http://hg.netbeans.org/main/nb-javac?cmd=changeset;node=4c07517dbd79
changeset 2ed03cda8e85 in main-silver
details: http://hg.netbeans.org/main-silver?cmd=changeset;node=2ed03cda8e85
Comment 14 Dusan Balek 2009-03-24 11:57:30 UTC
*** Issue 141521 has been marked as a duplicate of this issue. ***
Comment 15 Jesse Glick 2010-03-24 16:58:40 UTC
Similar exception just thrown in dev build (see exception reporter - claims it will open a new bug). Seems to be some problem with Enum.valueOf in JDK sources.
Comment 16 Marian Mirilovic 2010-04-22 10:34:07 UTC
v/c


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo