Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 151269 - "OK" button in "New Connection" dialog becomes unabled during connection attempt
"OK" button in "New Connection" dialog becomes unabled during connection attempt
Status: VERIFIED FIXED
Product: db
Classification: Unclassified
Component: Code
6.x
All All
: P2 (vote)
: 6.x
Assigned To: Rob Englander
issues@db
65fixes1-verified
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-24 13:15 UTC by Roman Mostyka
Modified: 2008-12-11 22:30 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Roman Mostyka 2008-10-24 13:16:07 UTC
1. Open "New Connection" dialog, type necessary parameters, but type wrong host and click "OK". IDE tried to connect to
DB and "OK" button is disabled.
2. Change something in "New Connection" dialog.

Result: Button "OK" becomes enabled, but previous attempt isn't finished. If click "OK" two connection processes will bu
running and, at least for me, they won't ever finish.
Comment 1 Rob Englander 2008-10-29 14:39:19 UTC
This has a target milestone of 7.0 and isn't marked with 65fixes1-candidate.  Should I address this
issue or leave it.
Comment 2 Roman Mostyka 2008-10-29 17:57:06 UTC
Actually since it P2, I prefer to have fix for this issue in Patch 1.
But if it is hard to fix till Patch 1 milestone, then you can change target milestone back to 7.0 and remove status
whiteboard.
Comment 3 Rob Englander 2008-10-29 17:59:50 UTC
I think I'll be able to fix it.  I was just confused because of the status whiteboard and target milestone.

Thanks for updating it.
Comment 4 Rob Englander 2008-10-30 14:10:28 UTC
Roman, can you give me a database URL that you're using?  I'm not able to reproduce this.  I always
get a failed connection dialog pretty quickly.

Here's my understanding of the problem.  When there is a long delay in attempting the connection, the user
can actually modify fields and attempt another connection.  That's bad.  It sounds like a second problem is
that there's no way to cancel a connection attempt.  

I don't think we should be allowing the user to do anything on the New Connection dialog while the connection
is being established (or failing to be established).  And I need to understand why you aren't getting a response
indicating a failed connection.
Comment 5 Rob Englander 2008-10-30 15:34:56 UTC
Thanks to Roman for pointing me to a db that exposes this.

My plan is to disable the form fields while the connection is being
established.  This will prevent the user from making another attempt
while that process is underway.  Cancel already works properly when
there is properly only 1 connection attempt underway.

The only question I have is "do we want to provide a better indication to
the user that the connection attempt is underway?".  My suggestion would
be to embed a progress bar at the bottom of the dialog.  But maybe we can leave
that part as an enhancement for NB 7?
Comment 6 Roman Mostyka 2008-10-30 15:40:48 UTC
I like your idea. I filed appropriate ENHANCEMENT issue #151873.
Comment 7 Rob Englander 2008-10-30 22:57:42 UTC
563336a2beef
Comment 8 Quality Engineering 2008-10-31 04:48:16 UTC
Integrated into 'main-golden', will be available in build *200810310201* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/563336a2beef
User: Rob Englander <mindstream@netbeans.org>
Log: #151269 Disable user input on New Connection dialog while connection is being established.
Comment 9 Roman Mostyka 2008-10-31 12:59:26 UTC
Verified with build 081031.
Comment 10 rbalada 2008-11-14 12:59:14 UTC
I've transplanted the changeset http://hg.netbeans.org/main/rev/563336a2beef into release65_fixes repository as
http://hg.netbeans.org/release65_fixes/rev/569165dda9dc
Comment 11 rbalada 2008-11-14 13:03:38 UTC
Oops correction:
I've transplanted the changeset http://hg.netbeans.org/main/rev/563336a2beef into release65_fixes repository as
http://hg.netbeans.org/release65_fixes/rev/f5e819675738


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo