Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 151262 - Ability to set the line delimiter of Editor and convert line delimiter of a file
Ability to set the line delimiter of Editor and convert line delimiter of a file
Status: RESOLVED DUPLICATE of bug 72515
Product: editor
Classification: Unclassified
Component: Formatting & Indentation
6.x
All All
: P3 (vote)
: TBD
Assigned To: issues@editor
issues@editor
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-24 12:19 UTC by desmond_kirrane
Modified: 2008-10-25 18:42 UTC (History)
0 users

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description desmond_kirrane 2008-10-24 12:19:48 UTC
In Eclispe you can set the line delimiter used to Windows, MacOS or Unix.
(e.g. Window > Preferences > General > Workspace > 'New text file line delimiter' > Other > Unix)

In Eclispe you can also convert an existing files to delimiter
To convert existing files, open file for editing and for the currently edited file, go to the menu:
(File -> Convert Line Delimiters To > Unix)


NetBeans is not a powerful.
http://wiki.netbeans.org/FaqEditorEOLs
For existing files NetBeans uses line separator of the first line.
For new files (constructed from templates) the editor uses platform-default line separator.
Comment 1 Petr Dvorak 2008-10-25 18:42:49 UTC
This is already requested, thank you.

*** This issue has been marked as a duplicate of 72515 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo