Bug 151232 - [65cat] IllegalArgumentException: Null ElementHandle not supported for JavaElementImpl, ensure it is set for <ClassElementDescriptor: MissionHandlerPeer$NetworkMetricComparator for file C:\Projects\SensorPlan
[65cat] IllegalArgumentException: Null ElementHandle not supported for JavaEl...
Status: RESOLVED FIXED
Product: third-party
Classification: Unclassified
Component: sqe tools
6.x
All All
: P1 (vote)
: TBD
Assigned To: sreimers
sreimers
http://statistics.netbeans.org/except...
EXCEPTIONS_REPORT
:
: 164765 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-24 02:04 UTC by wobster
Modified: 2009-09-29 00:44 UTC (History)
6 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (1011 bytes, text/plain)
2008-10-24 02:04 UTC, wobster
Details
stacktrace (1.05 KB, text/plain)
2008-10-24 09:28 UTC, malakim
Details
stacktrace (998 bytes, text/plain)
2009-08-18 23:36 UTC, Jesse Glick
Details

Note You need to log in before you can comment on or make changes to this bug.
Description wobster 2008-10-24 02:04:04 UTC
Build: NetBeans IDE Dev (Build 200810230201)
VM: Java HotSpot(TM) Client VM, 10.0-b23, Java(TM) SE Runtime Environment, 1.6.0_07-b06
OS: Windows XP, 5.1, x86

User Comments:
wobster: just running find bugs on my codebase

giorgio42: After running Findbugs on a small project.

GUEST: Running the Findbugs SQE Plugin

GUEST: working with SQE

wobster: just running find bugs on my codebase



Stacktrace: 
java.lang.IllegalArgumentException: Null ElementHandle not supported for JavaElementImpl, ensure it is set for <ClassElementDescriptor: MissionHandlerPeer$NetworkMetricComparator for file C:\Projects\SensorPlanning\modules\Mission\src\com\ticomgeo\mission\MissionHandlerPeer.java>!
        at org.nbheaven.sqe.core.java.search.impl.JavaElementImpl.<init>(JavaElementImpl.java:56)
        at org.nbheaven.sqe.core.java.search.SearchUtilities.findClassElement(SearchUtilities.java:55)
        at org.nbheaven.sqe.bridge.findbugs.output.BugAnnotationProcessor.annotateClass(BugAnnotationProcessor.java:239)
        at org.nbheaven.sqe.bridge.findbugs.output.BugAnnotationProcessor.annotateSourceFile(BugAnnotationProcessor.java:190)
        at org.nbheaven.sqe.codedefects.core.spi.AnnotationToggleListener$1.run(AnnotationToggleListener.java:64)
        at org.openide.util.RequestProcessor$Task.run(RequestProcessor.java:572)
Comment 1 wobster 2008-10-24 02:04:14 UTC
Created attachment 72569 [details]
stacktrace
Comment 2 malakim 2008-10-24 09:28:07 UTC
Build: NetBeans IDE 6.5 RC1 (Build 200810171318)
VM: Java HotSpot(TM) Client VM, 11.0-b15, Java(TM) SE Runtime Environment, 1.6.0_10-b33
OS: Windows XP, 5.1, x86

User Comments: 
Thrown when browsing FindBugs results in SQE

Stacktrace: 
java.lang.IllegalArgumentException: Null ElementHandle not supported for JavaElementImpl, ensure it is set for <ClassElementDescriptor: PlayNowManagerService$DateComparator for file C:\Code\PN5_2\trunk\FrontEndMobile\frontendmobile-war\src\main\java\com\sonyericsson\playnow\frontend\mobile\service\manager\PlayNowManagerService.java>!
        at org.nbheaven.sqe.core.java.search.impl.JavaElementImpl.<init>(JavaElementImpl.java:56)
        at org.nbheaven.sqe.core.java.search.SearchUtilities.findClassElement(SearchUtilities.java:55)
        at org.nbheaven.sqe.bridge.findbugs.output.BugAnnotationProcessor.annotateClass(BugAnnotationProcessor.java:239)
        at org.nbheaven.sqe.bridge.findbugs.output.BugAnnotationProcessor.annotateSourceFile(BugAnnotationProcessor.java:190)
        at org.nbheaven.sqe.codedefects.core.api.install.OpenTopComponentsListener$1.run(OpenTopComponentsListener.java:82)
        at org.openide.util.RequestProcessor$Task.run(RequestProcessor.java:572)
Comment 3 malakim 2008-10-24 09:28:17 UTC
Created attachment 72574 [details]
stacktrace
Comment 4 Lukas Hasik 2008-10-24 10:16:35 UTC
this exception is coming from findbigs code, please report directly to them as they don't wwatch the NB issuezilla,
thank you.
Comment 5 Exceptions Reporter 2009-02-20 09:43:00 UTC
This issue has already 20 duplicates 
see http://statistics.netbeans.org/exceptions/detail.do?id=73119
Comment 6 Jesse Glick 2009-08-18 23:36:21 UTC
Build: NetBeans IDE Dev (Build 090817)
VM: Java HotSpot(TM) Client VM, 14.1-b02, Java(TM) SE Runtime Environment, 1.6.0_15-b03
OS: Linux, 2.6.28-14-generic, i386

User Comments: 
Opening nb_all/hudson/src/**.java w/ SQE FB detector active.

Stacktrace: 
java.lang.IllegalArgumentException: Null ElementHandle not supported for JavaElementImpl, ensure it is set for <ClassElementDescriptor: StartJobAction$1 for file /space/src/nb/core-main/hudson/src/org/netbeans/modules/hudson/ui/actions/StartJobAction.java>!
        at org.nbheaven.sqe.core.java.search.impl.JavaElementImpl.<init>(JavaElementImpl.java:56)
        at org.nbheaven.sqe.core.java.search.SearchUtilities.findClassElement(SearchUtilities.java:55)
        at org.nbheaven.sqe.bridge.findbugs.output.BugAnnotationProcessor.annotateClass(BugAnnotationProcessor.java:239)
        at org.nbheaven.sqe.bridge.findbugs.output.BugAnnotationProcessor.annotateSourceFile(BugAnnotationProcessor.java:190)
        at org.nbheaven.sqe.codedefects.core.api.install.OpenTopComponentsListener$1.run(OpenTopComponentsListener.java:82)
        at org.openide.util.RequestProcessor$Task.run(RequestProcessor.java:602)
Comment 7 Jesse Glick 2009-08-18 23:36:26 UTC
Created attachment 86416 [details]
stacktrace
Comment 8 Exceptions Reporter 2009-08-18 23:36:32 UTC
This issue already has 51 duplicates 
see http://statistics.netbeans.org/exceptions/detail.do?id=73119
Comment 9 Jesse Glick 2009-09-28 17:51:17 UTC
*** Issue 164765 has been marked as a duplicate of this issue. ***
Comment 10 Jesse Glick 2009-09-28 17:52:19 UTC
a723a2d74d22 in sqe repo.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo