Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 151179 - Alt-Tab Focus issues
Alt-Tab Focus issues
Status: RESOLVED DUPLICATE of bug 73960
Product: ide
Classification: Unclassified
Component: Code
6.x
PC Windows XP
: P1 (vote)
: TBD
Assigned To: issues@ide
issues@ide
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-23 16:38 UTC by compucoder
Modified: 2008-10-23 19:57 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description compucoder 2008-10-23 16:38:20 UTC
When you use Alt-Tab to switch between NB and another app and then switch back it can keep the NB IDE in Alt mode. This
is dangerous as you may start typing and instead of writing code you could execute an action which could be bad.

To reproduce just use Alt-Tab to switch between NB and another program and keep doing it so you are flipping between
them and you will see it stuck in Alt-Mode.

I think you need to add an item in your onWindowFocus handler that makes sure Alt-mode is off and that the editor window
has focus for editing.

Thanks.
Comment 1 Jana Maleckova 2008-10-23 19:57:08 UTC

*** This issue has been marked as a duplicate of 73960 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo