Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 151108 - Cannot update Autoupdate Services in specific cases
Cannot update Autoupdate Services in specific cases
Status: VERIFIED FIXED
Product: platform
Classification: Unclassified
Component: Autoupdate
6.x
All All
: P2 (vote)
: 6.x
Assigned To: Jiri Rechtacek
issues@platform
65fixes1-verified
:
Depends on:
Blocks: 150610
  Show dependency treegraph
 
Reported: 2008-10-23 10:06 UTC by Jiri Rechtacek
Modified: 2009-02-19 20:23 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
ClassNotFound exception (1.91 KB, text/plain)
2008-10-23 10:12 UTC, Jiri Rechtacek
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jiri Rechtacek 2008-10-23 10:06:54 UTC
In such conditions:
1) o.n.m.autoupdate.services has a update
2) some modules from other cluster like o.n.profiler depends on newer version
=> new updater will be installed into profiler3 cluster instead of platform9 cluster. It makes Autoupdate Services be
unavailable after restart. ClassNotFoundException: org.netbeans.updater.XMLUtil will thrown always.
A workaround: never deliver update of Autoupdate Services and updates of dependent modules together.
Comment 1 Jiri Rechtacek 2008-10-23 10:12:58 UTC
Created attachment 72522 [details]
ClassNotFound exception
Comment 2 Jiri Rechtacek 2008-10-23 14:14:14 UTC
fixed in rev/0c4340753abb
Comment 3 Lukas Hasik 2008-10-23 14:35:24 UTC
@sustaining: please, be aware what situation is not allowed for the patch. 
Comment 4 Quality Engineering 2008-10-24 04:17:24 UTC
Integrated into 'main-golden', will be available in build *200810240201* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/0c4340753abb
User: Jiri Rechtacek <jrechtacek@netbeans.org>
Log: #151108: Cannot update Autoupdate Services in specific cases
Comment 5 Jaromir Uhrik 2008-11-19 14:27:57 UTC
v.
Comment 6 pgebauer 2008-11-21 10:21:47 UTC
The fix has been ported into the release65_fixes repository.

http://hg.netbeans.org/release65_fixes/rev/bfb0a776aa74

Comment 7 Jaromir Uhrik 2008-12-02 15:36:52 UTC
Product Version: NetBeans IDE 6.5 (Build 200811100001)
Java: 1.6.0_10; Java HotSpot(TM) Client VM 11.0-b15
System: Windows XP version 5.1 running on x86; Cp1252; en_US (nb)

Cannot reproduce in the build above containing 6.5 patch1 - changing the status whiteboard to 65fixes1-verified.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo