Bug 150902 - [65cat] IllegalArgumentException at java.net.URI.create
[65cat] IllegalArgumentException at java.net.URI.create
Status: RESOLVED FIXED
Product: apisupport
Classification: Unclassified
Component: Project
6.x
All All
: P3 (vote)
: 6.x
Assigned To: Jiri Skrivanek
issues@apisupport
http://statistics.netbeans.org/except...
EXCEPTIONS_REPORT
: SPACE_IN_PATH
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-21 16:54 UTC by sunbiz
Modified: 2009-04-23 08:56 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (5.94 KB, text/plain)
2008-10-21 16:54 UTC, sunbiz
Details

Note You need to log in before you can comment on or make changes to this bug.
Description sunbiz 2008-10-21 16:54:32 UTC
Build: NetBeans IDE Dev (Build 200810210201)
VM: Java HotSpot(TM) Client VM, 11.0-b15, Java(TM) SE Runtime Environment, 1.6.0_10-rc2-b32
OS: Windows Vista, 6.0, x86

Stacktrace: 
java.lang.IllegalArgumentException
        at java.net.URI.create(URI.java:842)
        at org.netbeans.modules.apisupport.project.layers.WritableXMLFileSystem.lastModified(WritableXMLFileSystem.java:1022)
        at org.openide.filesystems.AbstractFileObject.initLastModified(AbstractFileObject.java:94)
        at org.openide.filesystems.AbstractFileObject.lastModified(AbstractFileObject.java:175)
        at org.openide.filesystems.AbstractFileObject.<init>(AbstractFileObject.java:79)
        at org.openide.filesystems.AbstractFileSystem.createFileObject(AbstractFileSystem.java:447)
Comment 1 sunbiz 2008-10-21 16:54:46 UTC
Created attachment 72401 [details]
stacktrace
Comment 2 rmichalsky 2008-11-22 21:55:56 UTC
Caused by invalid path passed from GrailsProjectFactory, reassigning.
Comment 3 Petr Hejl 2009-04-20 12:21:45 UTC
Seems like unrelated issue in filesystem.
Comment 4 Jiri Skrivanek 2009-04-21 12:29:50 UTC
Spaces in path have to be escaped to get valid URL.
http://hg.netbeans.org/core-main/rev/d90e5ece3dd4
Comment 5 Jesse Glick 2009-04-21 16:27:02 UTC
A unit test for this would be good.
Comment 6 Quality Engineering 2009-04-22 08:39:02 UTC
Integrated into 'main-golden', will be available in build *200904220201* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/d90e5ece3dd4
User: Jiri Skrivanek <jskrivanek@netbeans.org>
Log: #150902 - Spaces in path have to be escaped to get valid URL.
Comment 7 Quality Engineering 2009-04-23 08:56:15 UTC
Integrated into 'main-golden', will be available in build *200904230201* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/2a3c86d1786c
User: Jiri Skrivanek <jskrivanek@netbeans.org>
Log: #150902 - test added.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo