Bug 150764 - Set as main project from menu and still run main project disabled
Set as main project from menu and still run main project disabled
Status: VERIFIED FIXED
Product: python
Classification: Unclassified
Component: Projects
6.x
All All
: P1 (vote)
: 6.x
Assigned To: ardavis26
nbpythonqa
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-20 19:03 UTC by tonybeckham
Modified: 2009-01-15 01:59 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description tonybeckham 2008-10-20 19:03:38 UTC
If there are several projects open and you use the Menubar item "Run|Set Main Project" then selecting a project, the
Run|Run Main Project item is still disabled.

System:
Product Version: NetBeans IDE 6.5 RC1 (Build 20081020152705)
Java: 1.5.0_16; Java HotSpot(TM) Client VM 1.5.0_16-133
System: Mac OS X version 10.5.5 running on i386; MacRoman; en_US (nb)

Steps:
-Open several existing projects
-From the Menubar select Run -> Set Main Project -> choose one of your open projects.  Selected Project should now be in
Bold
-Got to the Run menuitem and Run Main Project is still disabled.
Comment 1 tonybeckham 2008-10-20 19:11:44 UTC
Unable to reproduce again.  Not sure what had happened.  Closing the projects that I had opened that I was seeing the
issue with, restarting the ide then trying again and everything was working fine.
Comment 2 Peter Lam 2008-10-29 20:10:57 UTC
confirmed. I can't reproduce either with recent builds.
Comment 3 tonybeckham 2008-10-29 22:18:10 UTC
I found a case to reproduce.

1. Remove .netbeans
2. Start IDE
3. Open existing project, it will not be set as main project and run is disabled
4. Use the Run menu item set as main project and select the project, still run main is disabled
Comment 4 ardavis26 2008-11-02 22:32:18 UTC
adjusted the decision that decides if active
Comment 5 Peter Lam 2008-11-04 17:51:00 UTC
verified in build 146 (20081104041628)


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo