Bug 150696 - Unable to profile NetBeans module/module suite on Windows
Unable to profile NetBeans module/module suite on Windows
Status: VERIFIED FIXED
Product: profiler
Classification: Unclassified
Component: Base
6.x
All Windows Vista
: P1 (vote)
: 6.x
Assigned To: Jiri Sedlacek
issues@profiler
: REGRESSION, SPACE_IN_PATH
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-20 10:12 UTC by Jiri Sedlacek
Modified: 2008-10-22 20:52 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jiri Sedlacek 2008-10-20 10:12:00 UTC
Steps to reproduce:

 1/ Install the IDE into a path containing space
 2/ Create sample PaintApp application
 3/ Try to profile it, profiling session won't start
Comment 1 Jiri Sedlacek 2008-10-20 10:17:25 UTC
This is a regression caused by fixing Issue 124345. No NB module/module suite can be profiled when using an IDE
installed in a path containing space on Windows.
Comment 2 Jiri Sedlacek 2008-10-20 10:30:31 UTC
Fixed in profiler-main:

changeset:   105704:aa4f5616f481
date:        Mon Oct 20 11:26:56 2008 +0200
summary:     Bugfix #150696 Fixed -agentpath parameter for profiling NB module/suite on Windows
Comment 3 Jiri Sedlacek 2008-10-20 10:35:28 UTC
Suggesting that this bug should be fixed in NetBeans 6.5. There is a workaround - move/reinstall the IDE into a path
without space - but this problem affects the default configuration on Windows (C:\Program Files\...) and breaks a
functionality which worked fine in all previous releases.
Comment 4 Tomas Hurka 2008-10-20 10:39:25 UTC
This should be definitely fixed in NB 6.5
Comment 5 Quality Engineering 2008-10-21 04:06:06 UTC
Integrated into 'main-golden', will be available in build *200810210201* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/aa4f5616f481
User: Jiri Sedlacek <jis@netbeans.org>
Log: Bugfix #150696 Fixed -agentpath parameter for profiling NB module/suite on Windows
Comment 6 mariadavydova 2008-10-22 14:38:09 UTC
verified in build 20081022
Comment 7 Tomas Hurka 2008-10-22 14:50:03 UTC
I reviewed the patch and it can be integrated into release65 clone.
Comment 8 Tomas Hurka 2008-10-22 20:52:50 UTC
Integrated into release65 clone

http://hg.netbeans.org/release65/rev/64320a61eb22




By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo