Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 150693 - Regression in inaccuracy tests from 17-10-2008
Regression in inaccuracy tests from 17-10-2008
Status: VERIFIED FIXED
Product: cnd
Classification: Unclassified
Component: Editor
6.x
All Linux
: P2 (vote)
: 6.x
Assigned To: Vladimir Voskresensky
issues@cnd
65fixes1-verified
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-20 09:46 UTC by soldatov
Modified: 2009-02-19 20:29 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
fixup to workaround jdk bug (5.57 KB, patch)
2008-10-30 17:06 UTC, Vladimir Voskresensky
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description soldatov 2008-10-20 09:46:28 UTC
We have regression in inaccuracy tests from 17-10-2008.
Scenario:
- Launch IDE with fresh user directory
- Open Perl project
- Open config.h file in editor
==> This code is highlighted as error:
#if 42 != 1 && 42 != 42
#   include "Bletch: How does this C preprocessor concatenate tokens?"
#endif

P2 because I see this problem in RC1 also.
Comment 1 Vladimir Voskresensky 2008-10-20 12:30:33 UTC
most probably problem is in JVM. Problem is reproducible only on 
#java -version
java version "1.6.0_10"
Java(TM) SE Runtime Environment (build 1.6.0_10-b33)
Java HotSpot(TM) 64-Bit Server VM (build 11.0-b15, mixed mode)

everything is fine with 1.6.0_05 and 1.5.0_16

Looks like the problem with inlining of simple functions.

Reassigning to QA for evaluation of possible solutions.
Comment 2 Egor Ushakov 2008-10-20 13:51:06 UTC
Submitted P1 bug on jvm:
http://bt2ws.central.sun.com/CrPrint?id=6761298
Comment 3 Leonid Lenyashin 2008-10-20 14:46:12 UTC
Please evaluate
Comment 4 Alexander Pepin 2008-10-20 14:51:21 UTC
not a stopper for NB6.5 release as non-reproducible with previous java versions (earlier then 1.6.0_10) but should be
fixed in next release and in patch for NB6.5
Comment 5 julieg 2008-10-21 20:21:33 UTC
OpenSolaris 11/08 is going to have jdk1.6 update 10 as the default.
Does it make this bug a showstopper?
Comment 6 Leonid Lenyashin 2008-10-21 20:31:05 UTC
It does not look as a showstopper under any circumstances. And in this case the issue has been reported as purely Linux
issue (may be even only Linux64 issue), so I can not believe it affects OpenSolaris.
QA may want to double check it.

Leonid.
Comment 7 Vladimir Voskresensky 2008-10-22 12:26:16 UTC
public visible java bug:
http://bugs.sun.com/bugdatabase/view_bug.do?bug_id=6761298
Comment 8 Vladimir Voskresensky 2008-10-22 13:44:30 UTC
just a note to QA: We can not fix this problem on our side, so not clear which fix could be included in 6.5 patch? 
Comment 9 Vladimir Voskresensky 2008-10-30 12:13:03 UTC
I have found some tricks how to change code to be not overkilled by java machine 6 Update 10
Comment 10 Vladimir Voskresensky 2008-10-30 17:06:53 UTC
Created attachment 72928 [details]
fixup to workaround jdk bug
Comment 11 Vladimir Voskresensky 2008-11-01 11:06:09 UTC
another workaround is added due to bug in jdk6 Update 10

http://hg.netbeans.org/main?cmd=changeset;node=caf8a257aebe
Comment 12 Quality Engineering 2008-11-01 16:31:12 UTC
Integrated into 'main-golden', will be available in build *200811011401* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/caf8a257aebe
User: Vladimir Voskresensky <vv159170@netbeans.org>
Log: workaround (due to bug in jdk6u10) for IZ#150693: Regression in inaccuracy tests from 17-10-2008
Comment 13 soldatov 2008-11-20 15:22:49 UTC
Verified in 200811200201 build
Comment 14 pslechta 2008-11-21 12:15:36 UTC
The fix was ported into release65_fixes repository.

http://hg.netbeans.org/release65_fixes/rev/b1911198bbf7
Comment 15 soldatov 2008-12-02 13:59:29 UTC
verified in nb6.5 with patch1


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo