Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 150687 - There has to be Reindex/Refresh action for source node
There has to be Reindex/Refresh action for source node
Status: RESOLVED FIXED
Product: php
Classification: Unclassified
Component: Code
6.x
All All
: P1 (vote)
: 6.x
Assigned To: Tomas Mysik
issues@php
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-20 09:12 UTC by Petr Pisl
Modified: 2009-11-25 02:45 UTC (History)
5 users (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Petr Pisl 2008-10-20 09:12:33 UTC
There are a few important case, when user needs to invoke reindexing sources. It's usually when the project is in a CVS
and the sources are updated externally. Next example is that a part of sources are regenerated by an external tool, like
UML or some tools like Propel or Hibernate.

The problem is that if there is not created FileObject for the source, which is changed externally then is not reindexed
after the change and all features like cc, Go To .... work with the old version. User has to restart the IDE to get it
work correctly in such case.

This is not problem only in PHP but for every project in NetBeans.
Comment 1 rmatous 2009-02-19 14:18:08 UTC
This issue blocks usage of netbeans together with other external tools (details in previous comment)!

Jano, any idea how to fix it from ui point of view? Adding refreshing action? Any objections? 

Comment 2 Petr Jiricka 2009-03-08 23:01:02 UTC
This is a problem not only for PHP, but also for Java - see issue 159631. Reassigning to Ondra L, I heard Jano does not
have much time for NetBeans these days.
Comment 3 Ondrej Langr 2009-03-09 13:20:41 UTC
Refresh action on respective nodes is probably the right way to go.

I guess it should only be present on the nodes (Source Packages, Test Packages), not project on project node. Because
what is essentially refreshed (or re-indexed) is really just project sources, not project configuration files. 
Comment 4 rmatous 2009-03-09 13:57:40 UTC
I would find it much better to have this action just on project node. Implementation naturally won't care about project
configuration files. I don't think that users should care about what to refresh (sources, tests, selenium), after
running any black box 3-rd party application or command. 
Comment 5 Tomas Mysik 2009-05-04 17:25:17 UTC
I will be the owner of this issue.
Comment 6 Tomas Mysik 2009-07-01 09:52:41 UTC
I agree with Radek, "Refresh" should be on project's node (just one action, there can be more directories
underneath project directory, not only sources or tests).
Comment 7 Ondrej Langr 2009-07-01 11:18:42 UTC
No problem with me, sounds reasonable.
Comment 8 David Strupl 2009-07-02 12:55:05 UTC
Vita mentioned that the API is already there: it should be no problem adding the action to e.g. the PHP project node.
Comment 9 Tomas Mysik 2009-11-25 02:45:53 UTC
I guess we can close this issue, we have Source > Scan for external changes action for NB 6.8.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo