Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 150638 - Javadoc tooltip for methods, classes and fields in editor
Javadoc tooltip for methods, classes and fields in editor
Status: RESOLVED DUPLICATE of bug 95691
Product: java
Classification: Unclassified
Component: Editor
6.x
All All
: P3 (vote)
: TBD
Assigned To: Jan Lahoda
issues@java
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-19 13:23 UTC by yoshtec
Modified: 2008-10-20 10:16 UTC (History)
0 users

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description yoshtec 2008-10-19 13:23:50 UTC
In the Editor pane hovering the mouse for a while above a method, field or class should display a javadoc tooltip. 
There are two reasons:
1. Reading and understanding code is extremely dependent on understanding what happens inside the functions, or meaning
of the class or field. 
2. Quickcheck for written javadoc. looking at the correctly formatted tooltip of an javadoc can reveal errors in complex
javadoc comments. For instance javadoc including code examples, or the inheritance of javadoc may not always be clear at
first sight.

(Testing and using Netbeans after using Eclipse makes on miss this feature.)
Comment 1 Jiri Prox 2008-10-20 10:16:56 UTC

*** This issue has been marked as a duplicate of 95691 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo