Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 150610 - Plugin install is not able to resolve the module dependecy properly.
Plugin install is not able to resolve the module dependecy properly.
Status: VERIFIED FIXED
Product: platform
Classification: Unclassified
Component: Plugin Manager
6.x
All All
: P2 (vote)
: 6.x
Assigned To: Jiri Rechtacek
issues@platform
65fixes1-verified
:
: 150966 (view as bug list)
Depends on: 151108
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-18 14:34 UTC by Satyaranjan D
Modified: 2009-02-19 20:23 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
Error (123.83 KB, image/png)
2008-10-18 14:40 UTC, Satyaranjan D
Details
Download Tab (154.35 KB, image/png)
2008-10-18 14:41 UTC, Satyaranjan D
Details
Available Tab (122.34 KB, image/png)
2008-10-18 14:41 UTC, Satyaranjan D
Details
Generic Portlet 2.92 (1.34 MB, application/octet-stream)
2008-10-20 09:56 UTC, Satyaranjan D
Details
Spring Portlet (226.04 KB, application/octet-stream)
2008-10-20 09:57 UTC, Satyaranjan D
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Satyaranjan D 2008-10-18 14:34:48 UTC
I am using the latest netbeans build 
Product Version  = NetBeans IDE 6.5 RC1 (Build 200810171318)
Operating System = Windows XP version 5.1 running on x86

Scenario:
- Install NB build
- Go to plugin installer
- Generic Portlet module 2.0.6 version is available in NB Update Center.

- Try to install Spring Portlet 1.0 and Generic Portlet 2.92 from local machine from Download tab.

- Spring Portlet 1.0 requires minimum Generic Portlet v2.9 . So ideally the plugin installer should install Generic
Portlet 2.9 from local download and then install Spring Portlet 1.0 . But looks like it tries to check the Generic
Portlet version 2.0.6 from update center and throws error 

"The plugin Generic Portlets is requested in version >= 2.9 but only 2.0.6 was found.  
The following plugin is affected:  
     Spring Portlets "

- So while installing from a local path, why does the plugin installer trying to resolve the dependency modules from the
auc before checking the dependency module's existence from the local path mentioned in the "Download" tab ?

This scenario is working fine with NB 6.5 Beta.
Comment 1 Satyaranjan D 2008-10-18 14:40:31 UTC
Created attachment 72178 [details]
Error
Comment 2 Satyaranjan D 2008-10-18 14:41:18 UTC
Created attachment 72179 [details]
Download Tab
Comment 3 Satyaranjan D 2008-10-18 14:41:45 UTC
Created attachment 72180 [details]
Available Tab
Comment 4 Jiri Rechtacek 2008-10-20 09:22:47 UTC
Could you please attach your NBMs to reproduce with them. It works for me on my test NBMs. Thanks
Comment 5 Satyaranjan D 2008-10-20 09:56:39 UTC
Created attachment 72245 [details]
Generic Portlet 2.92
Comment 6 Satyaranjan D 2008-10-20 09:57:34 UTC
Created attachment 72246 [details]
Spring Portlet
Comment 7 Jiri Rechtacek 2008-10-20 10:00:49 UTC
Thank you. I'm investigating...
Comment 8 Satyaranjan D 2008-10-20 10:03:39 UTC
Steps to reproduce :

- Download the attached Generic Portlet & Spring Portlet nbms
- Go to Tools > Plugin
- Go to available plugins, check if all the available plugins are visible. Please click "Reload Catalog" and wait to see
all the available plugins.

- You can see a plugin "Generic Portlet" (v. 2.0.6) under PortalPack category.
- Then go to download tab and add both attached nbms. Try to install them.

Please let me know if you can reproduce this.
Comment 9 Jiri Rechtacek 2008-10-20 13:09:28 UTC
I can confirm this defect. As a workaround, mark the Update Center NetBeansRC1 as inactive in Setting tab and then try
install your NBMs again.
Comment 10 Satyaranjan D 2008-10-20 13:23:19 UTC
Thanks for the confirmation.
I saw the target release has been changed to 7.0 . Can't it be fixed in the NB 6.5 final release ?

Thanks
Comment 11 Jiri Rechtacek 2008-10-21 14:03:48 UTC
fixed in rev/87f676048c77

It is a real problem which appear once:
1) a plugin A is already stagged on UC (e.g. 1.0)
2) user installed in Download tab plugins A2.0, B1.0 where B depends on A > 1.0
=> PM report a broken dependency A > 1.0 due to A is available in version 1.0 only.

I agree it should be patch1 candidate.
Comment 12 Quality Engineering 2008-10-22 05:05:36 UTC
Integrated into 'main-golden', will be available in build *200810220201* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/87f676048c77
User: Jiri Rechtacek <jrechtacek@netbeans.org>
Log: #150610: Plugin install is not able to resolve the module dependecy properly
Comment 13 Jiri Rechtacek 2008-10-23 14:40:25 UTC
If you backport this issue, keep in mind a problem of installing patch of Autoupdate is some cases - issue 151108.
Comment 14 Satyaranjan D 2008-11-07 10:26:53 UTC
*** Issue 150966 has been marked as a duplicate of this issue. ***
Comment 15 Jaromir Uhrik 2008-11-19 14:28:27 UTC
Verified.
Comment 16 pgebauer 2008-11-21 10:19:58 UTC
The fix has been ported into the release65_fixes repository.

http://hg.netbeans.org/release65_fixes/rev/ba31a14b25c6

Comment 17 Jaromir Uhrik 2008-12-02 15:39:53 UTC
Product Version: NetBeans IDE 6.5 (Build 200811100001)
Java: 1.6.0_10; Java HotSpot(TM) Client VM 11.0-b15
System: Windows XP version 5.1 running on x86; Cp1252; en_US (nb)

Cannot reproduce in the build above containing 6.5 patch1 - changing the status whiteboard to 65fixes1-verified.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo