Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 150367 - spring sample is not working
spring sample is not working
Status: VERIFIED FIXED
Product: webservices
Classification: Unclassified
Component: REST
6.x
All Linux
: P1 (vote)
: 6.x
Assigned To: Ayub Khan
issues@webservices
65fixes2-verified
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-16 12:05 UTC by Lukas Jungmann
Modified: 2009-02-19 23:29 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Lukas Jungmann 2008-10-16 12:05:06 UTC
-create new websvc->customerDB Spring sample
-run it

issue 1) deploy on safe is disabled but should be enabled for all samples

issue 2) sping mvc welcome page is opened, but index.jsp should be opened instead

WA: point browser to index.jsp

issue 3) no table is visible

WA: s/getCustomerDBApp()/getCustomerDBSpringApp() on line 260 in restclient/ui/customerdbspring.js

issue 4) after enabling debugging in index.jsp browser shows:

"rest debug(12:41:59): customers is undefined, so skipping init of Customers"


at this point I'm giving up trying to run/check this sample since it should simply just work without any workarounds in
the same way as CustomerDB sample works.

Not a stopper for RC1, have to be fixed for FCS.
Comment 1 Ayub Khan 2008-10-16 20:10:18 UTC
This is a regression by switching to jersey 1.0.

Previously for a request http://localhost:8080/CustomerDB/resources/customers/ (mime application/json) we used to get

{customers:{"@uri":"http://localhost:8080/CustomerDB/resources/customers/","customer":[{"@uri":"http://localhost:8080/CustomerDB/resources/customers/1/","addressline1":"xyz","addressline2":"Suite
51","city":"Fort
Lauderdale","creditLimit":"100000","customerId":"1","discountCode":{"@uri":"http://localhost:8080/CustomerDB/resources/customers/1/discountCode/"},"email":"jumbocom@gmail.com","fax":"305-777-4635","name":"JumboCom4","phone":"305-777-4632","state":"FL","zip":"33015"},
...

now we get

{"@uri":"http://localhost:8080/CustomerDB/resources/customers/","customer":[{"@uri":"http://localhost:8080/CustomerDB/resources/customers/1/","addressline1":"xyz","addressline2":"Suite
51","city":"Fort
Lauderdale","creditLimit":"100000","customerId":"1","discountCode":{"@uri":"http://localhost:8080/CustomerDB/resources/customers/1/discountCode/"},"email":"jumbocom@gmail.com","fax":"305-777-4635","name":"JumboCom4","phone":"305-777-4632","state":"FL","zip":"33015"},
Comment 2 Ayub Khan 2008-10-16 20:11:49 UTC
Not just the spring sample, also customerdb sample, and all client stubs fails.
Comment 3 Ayub Khan 2008-10-17 19:46:13 UTC
Fixed in trunk
Comment 4 Quality Engineering 2008-10-18 15:52:41 UTC
Integrated into 'main-golden', will be available in build *200810181401* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/c771ff3b8fde
User: Ayub Khan <ayubskhan@netbeans.org>
Log: Fix issue#150367 - spring sample is not working
Comment 5 Lukas Jungmann 2008-10-20 15:50:26 UTC
issues 1 and 2 from original report are still valid
Comment 6 Ayub Khan 2008-10-20 17:36:46 UTC
Hi Lukas,

Which build did you try. trunk? rc1?

This fix is only in the trunk. If trunk, which build? Also did you try to cleanup
your userdir before trying this.

Thanks
Ayub
Comment 7 Ayub Khan 2008-10-20 17:40:36 UTC
Hi Lukas,

Correction! Sorry for the last comment.

Can you point me to the build you tried to test this.

Also did you try to cleanup
your userdir before trying this.

Thanks
Ayub
Comment 8 Lukas Jungmann 2008-10-20 18:46:45 UTC
trunk build from hudson[1], to be precise: netbeans-hudson-trunk-4099-java.zip built 20.10.2008 8:45:37 running on
jdk6-u10-b33 on win vista + did equivalent to rm -rf ~/.netbeans* before running IDE

[1]: http://deadlock.netbeans.org/hudson/job/trunk/
Comment 9 Lukas Jungmann 2008-10-20 19:20:22 UTC
re deploy on save for samples: see issue 149789 for how to fix ;-)
Comment 10 Ayub Khan 2008-10-20 20:51:40 UTC
Sorry, earlier I missed 1&2 issues. Now fixing in trunk for issues 1&2.
Comment 11 Lukas Jungmann 2008-10-20 22:01:32 UTC
all parts here are v. in trunk now, transplant both cs to release65 clone, please.

Thanks
Comment 12 Quality Engineering 2008-10-21 04:09:12 UTC
Integrated into 'main-golden', will be available in build *200810210201* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/db1a18e4b146
User: Ayub Khan <ayubskhan@netbeans.org>
Log: Fix issue#150367 - spring sample is not working
Comment 13 Ayub Khan 2008-12-01 23:01:00 UTC
*** Issue 153274 has been marked as a duplicate of this issue. ***
Comment 14 Ayub Khan 2008-12-01 23:05:06 UTC
*** Issue 153274 has been marked as a duplicate of this issue. ***
Comment 15 Ayub Khan 2008-12-02 22:41:16 UTC
I am sorry, the fix http://hg.netbeans.org/main/rev/c771ff3b8fde somehow didn't make it into NB6.5. We are planning to
put this fix into NB 6.5 patch2.
Comment 16 Lukas Jungmann 2008-12-03 12:22:06 UTC
it's fixed in trunk already, only not in 6.5 => TM=7.0M1
Comment 17 Lukas Jungmann 2008-12-03 12:22:49 UTC
v.
Comment 18 pslechta 2008-12-16 15:26:17 UTC
The fix was ported into release65_fixes repository.

http://hg.netbeans.org/release65_fixes/rev/e2ec2f6b6bf3
http://hg.netbeans.org/release65_fixes/rev/02a4f420ca92


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo