Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 150235 - Multiline alignment does not work
Multiline alignment does not work
Status: VERIFIED FIXED
Product: java
Classification: Unclassified
Component: Source
6.x
All All
: P2 (vote)
: 6.x
Assigned To: Dusan Balek
issues@java
65fixes1-verified
:
: 148048 152932 154279 155672 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-15 15:12 UTC by Jiri Prox
Modified: 2009-02-19 21:08 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jiri Prox 2008-10-15 15:13:03 UTC
Product Version: NetBeans IDE Dev (Build 200810150101) 
Java: 1.6.0_10-rc; Java HotSpot(TM) Client VM 11.0-b13
System: Linux version 2.6.22-15-generic running on i386; UTF-8; en_US (nb)

The multiline alignment formatting setting does not work, the code is always indented as continuation statement.

Steps to reproduce:
1) open file with method call,where each parameter is written on separate line
2) check all checkboxes in multiline alignment 
3) reformat code
-> the parameter are not aligned under the first one
Comment 1 Dusan Balek 2008-10-17 09:39:04 UTC
Fixed.

changeset c2b21278384d in main
details: http://hg.netbeans.org/main?cmd=changeset;node=c2b21278384d
Comment 2 Quality Engineering 2008-10-17 16:31:05 UTC
Integrated into 'main-golden', will be available in build *200810171401* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/c2b21278384d
User: Dusan Balek <dbalek@netbeans.org>
Log: Issue #150235: Multiline alignment does not work - fixed.
Comment 3 Jiri Prox 2008-10-29 11:02:06 UTC
*** Issue 148048 has been marked as a duplicate of this issue. ***
Comment 4 Jiri Prox 2008-11-18 16:57:23 UTC
*** Issue 152932 has been marked as a duplicate of this issue. ***
Comment 5 Jiri Prox 2008-11-20 10:37:26 UTC
v.
Comment 6 pgebauer 2008-11-21 15:36:15 UTC
The fix has been ported into the release65_fixes repository.

http://hg.netbeans.org/release65_fixes/rev/bf1c1a6b677b
Comment 7 Jiri Prox 2008-12-01 17:13:16 UTC
*** Issue 154279 has been marked as a duplicate of this issue. ***
Comment 8 Jiri Prox 2008-12-02 16:04:35 UTC
verified in patch1
Comment 9 Jiri Prox 2008-12-17 16:06:18 UTC
*** Issue 155672 has been marked as a duplicate of this issue. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo