Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 150198 - IllegalArgumentException: "null" expected to be an integer
IllegalArgumentException: "null" expected to be an integer
Status: VERIFIED FIXED
Product: obsolete
Classification: Unclassified
Component: Registration
6.x
All All
: P2 (vote)
: 6.x
Assigned To: mslama
issues@platform
http://statistics.netbeans.org/except...
EXCEPTIONS_REPORT 65fixes1-verified
:
: 132941 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-15 11:23 UTC by Marian Mirilovic
Modified: 2009-02-19 20:55 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Marian Mirilovic 2008-10-15 11:23:11 UTC
30 duplicates so far ... too old, so probably fixed ?

Build: NetBeans IDE 6.1 (Build 200804211638)
VM: Java HotSpot(TM) Client VM, 11.0-b11, Java(TM) SE Runtime Environment, 1.6.0_10-beta-b14
OS: Windows XP, 5.1, x86
User comments: 
STACKTRACE: (first 10 lines)
java.lang.IllegalArgumentException: "null" expected to be an integer
        at org.netbeans.modules.servicetag.Util.getIntValue(Util.java:101)
        at org.netbeans.modules.servicetag.Registry.parseServiceTag(Registry.java:495)
        at org.netbeans.modules.servicetag.Registry.getServiceTag(Registry.java:459)
        at org.netbeans.modules.reglib.NbServiceTagSupport.installSystemServiceTag(NbServiceTagSupport.java:639)
        at org.netbeans.modules.reglib.NbServiceTagSupport.createNbServiceTag(NbServiceTagSupport.java:194)
        at org.netbeans.modules.registration.NbInstaller.restored(NbInstaller.java:98)
        at org.netbeans.core.startup.NbInstaller.loadCode(NbInstaller.java:419)
        at org.netbeans.core.startup.NbInstaller.load(NbInstaller.java:340)
        at org.netbeans.ModuleManager.enable(ModuleManager.java:936)
        at org.netbeans.core.startup.ModuleList.installNew(ModuleList.java:428)
Comment 1 mslama 2008-10-27 15:37:17 UTC
It is known issue. Tumbleweed uses stclient.exe and JDK code is not able to distinguish this from Sun stclient.exe. Till
JDK will fix this I will stop using stclient.exe from our code.
Comment 2 mslama 2008-10-29 11:08:10 UTC
core-main #7b62f4d58fe2

Lukas candidate for next patch. Please mark it I never know what keyword for this and there is no corresponding keyword
in list of keywords.
Comment 3 mslama 2008-10-29 11:56:30 UTC
Patch from JDK contains JDK 6 API. It was removed:
core-main #dd92caa95316
Comment 4 Quality Engineering 2008-10-30 04:57:25 UTC
Integrated into 'main-golden', will be available in build *200810300201* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/7b62f4d58fe2
User: Marek Slama <mslama@netbeans.org>
Log: #150198: Handle incorrect stclient.exe.
Comment 5 mslama 2008-11-11 15:25:23 UTC
*** Issue 132941 has been marked as a duplicate of this issue. ***
Comment 6 Petr Chytil 2008-11-19 14:57:54 UTC
fix seems to be OK, verified 
Comment 7 pslechta 2008-11-19 16:13:26 UTC
The fix has been ported into release65_fixes repository.

http://hg.netbeans.org/release65_fixes/rev/32fa0655cb30
Comment 8 pslechta 2008-11-19 16:58:05 UTC
The fix had to be corrected for 6.5 patch 1 (that uses Java 1.5, the fix was designed for Java 1.6):

http://hg.netbeans.org/release65_fixes/rev/04001c2371e6


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo