Bug 150197 - Switch off Lexer's Token Hierarchy during formatting
Switch off Lexer's Token Hierarchy during formatting
Status: RESOLVED WONTFIX
Product: editor
Classification: Unclassified
Component: Formatting & Indentation
6.x
PC All
: P3 (vote)
: 7.1
Assigned To: Miloslav Metelka
issues@editor
: PERFORMANCE
: 198135 229099 232065 (view as bug list)
Depends on:
Blocks: 180620 214949
  Show dependency treegraph
 
Reported: 2008-10-15 11:19 UTC by Miloslav Metelka
Modified: 2016-07-07 07:28 UTC (History)
6 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Miloslav Metelka 2008-10-15 11:19:48 UTC
For complex embedding such as JSPs it would be beneficial to first analyze what formatting needs to be done (possibly
using lexer's token hierarchy). Once the analysis are done there are many small modifications done (typically
adding/removing a whitespace on formatted lines) and each modification updates the token hierarchy. It would improve
performance if the hierarchy would be deactivated for the formatting and activated at the end.
 I need to measure a rough performance gain from such change and also consider indentation api/spi impact.
Comment 1 Miloslav Metelka 2011-10-11 14:56:54 UTC
Token Hierarchy switches off after BaseTextUI.LENGTHY_ATOMIC_EDIT_THRESHOLD number of inserts/removals.

http://hg.netbeans.org/jet-main/rev/95341e17db29
Comment 2 Miloslav Metelka 2011-10-11 14:57:37 UTC
*** Bug 198135 has been marked as a duplicate of this bug. ***
Comment 3 Quality Engineering 2011-10-12 14:21:26 UTC
Integrated into 'main-golden'
Changeset: http://hg.netbeans.org/main-golden/rev/95341e17db29
User: Miloslav Metelka <mmetelka@netbeans.org>
Log: #150197 - Switch off Lexer's Token Hierarchy during formatting.
Comment 4 Miloslav Metelka 2011-10-20 09:16:32 UTC
Reopened since the fix had to be reverted due to issue 200270. I will implement some additional logic in order to fix this.
Comment 5 Miloslav Metelka 2013-09-02 08:08:56 UTC
*** Bug 229099 has been marked as a duplicate of this bug. ***
Comment 6 Miloslav Metelka 2013-09-02 08:50:21 UTC
*** Bug 232065 has been marked as a duplicate of this bug. ***
Comment 7 Martin Balin 2016-07-07 07:28:40 UTC
This old bug may not be relevant anymore. If you can still reproduce it in 8.2 development builds please reopen this issue.

Thanks for your cooperation,
NetBeans IDE 8.2 Release Boss


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo