Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 150071 - NoClassDefFoundError: org/netbeans/modules/glassfish/spi/ServerUtilities
NoClassDefFoundError: org/netbeans/modules/glassfish/spi/ServerUtilities
Status: VERIFIED FIXED
Product: serverplugins
Classification: Unclassified
Component: GlassFish
6.x
All All
: P3 (vote)
: 6.x
Assigned To: _ pcw
issues@serverplugins
http://statistics.netbeans.org/except...
EXCEPTIONS_REPORT, 65fixes1-verified
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-14 11:24 UTC by Lukas Hasik
Modified: 2009-02-19 23:04 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Lukas Hasik 2008-10-14 11:24:28 UTC
13 duplicates

Build: NetBeans IDE Dev (Build 200808251401)
VM: Java HotSpot(TM) 64-Bit Server VM, 10.0-b23, Java(TM) SE Runtime Environment, 1.6.0_07-b06
OS: Linux, 2.6.24-21-generic, amd64
User comments: 
STACKTRACE: (first 10 lines)
java.lang.NoClassDefFoundError: org/netbeans/modules/glassfish/spi/ServerUtilities
        at org.netbeans.modules.glassfish.javaee.Hk2OptionalFactory.finishServerInitialization(Hk2OptionalFactory.java:256)
        at org.netbeans.modules.j2ee.deployment.impl.ServerRegistry.init(ServerRegistry.java:147)
        at org.netbeans.modules.j2ee.deployment.impl.ServerRegistry.instancesMap(ServerRegistry.java:168)
        at org.netbeans.modules.j2ee.deployment.impl.ServerRegistry.getServerInstance(ServerRegistry.java:306)
        at org.netbeans.modules.j2ee.deployment.devmodules.api.Deployment.getJ2eePlatform(Deployment.java:448)
        at org.netbeans.modules.j2ee.earproject.EarProject$ProjectOpenedHookImpl.projectOpened(EarProject.java:476)
        at org.netbeans.spi.project.ui.ProjectOpenedHook$1.projectOpened(ProjectOpenedHook.java:81)
        at
org.netbeans.spi.project.ui.support.UILookupMergerSupport$OpenHookImpl.projectOpened(UILookupMergerSupport.java:193)
        at org.netbeans.spi.project.ui.ProjectOpenedHook$1.projectOpened(ProjectOpenedHook.java:81)
        at org.netbeans.modules.project.ui.OpenProjectList.notifyOpened(OpenProjectList.java:973)
Comment 1 _ pcw 2008-10-17 23:33:31 UTC
Appears to be caused by having an old version of glassfish.common installed instead of the current version.  All the
logs I checked show glassfish.common = 0.1.0 (Feb 2008!) when 0.4.0 is the current version as of this writing.

This ought not to be have been allowed in the first place so I'm checking to see if there is something wrong with the
versioning.

Anyway, for anyone who submitted this trace, use the updatecenter to get the latest updates of the GlassFish V3 plugins.
 If none are shown, uninstall all V3 plugins, restart the IDE and download them again.  Note that glassfish.common is a
library module -- it's not shown, but rather automatically downloaded when you select any of the language/platform
specific V3 modules.
Comment 2 Quality Engineering 2008-10-22 15:43:30 UTC
Integrated into 'main-golden', will be available in build *200810221401* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/371309db29fd
User: pcw@netbeans.org
Log: #150071 ClassNotFoundException due to glassfish.javaee having out-of-date dependency data for glassfish.common.  Updated glassfish.common, glassfish.javaee, and glassfish.jruby to be version 1.0 across the board and have correct dependency data.
Comment 3 _ pcw 2008-10-23 00:35:14 UTC
Fixed in trunk.  Marking as candidate for 6.5 patch 1.
Comment 4 _ pcw 2008-10-23 00:45:17 UTC
ATTN QE: If you concur on nomination of this for patch, please complete the process (verification, sustaining, etc.)

If not, please advise by what reasoning.
Comment 5 pslechta 2008-11-20 14:42:50 UTC
Please verify this issue so it can be part of NB 6.5 patch 1.
Comment 6 pgebauer 2008-11-24 09:31:21 UTC
The issue didn't pass the nomination process by nomination cut-off date. It has been marked as 65fixes2-candidate.
Comment 7 davisn 2008-11-26 01:06:03 UTC
The fix was verified. 
Since the bug has 13 duplicates, I'd like to nominate this bug in the top list candidate for the next patch
Thanks,
Comment 8 Petr Blaha 2008-11-26 07:57:59 UTC
The bug is verified.
Comment 9 pgebauer 2008-11-26 09:08:13 UTC
Let's try to include the issue to 65patch1.
Comment 10 pslechta 2008-11-26 15:19:59 UTC
The fix was ported into release65_fixes repository.

http://hg.netbeans.org/release65_fixes/rev/c3b8f5f0acf9


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo