Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 149958 - AssertionError in RunAsValidator.validateUploadDirectory(RunAsValidator.java:98)
AssertionError in RunAsValidator.validateUploadDirectory(RunAsValidator.java:98)
Status: RESOLVED FIXED
Product: php
Classification: Unclassified
Component: FTP Support
6.x
All All
: P3 (vote)
: 6.x
Assigned To: Tomas Mysik
issues@php
65fixes1-verified
:
: 151024 152565 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-13 15:30 UTC by Tomas Mysik
Modified: 2009-02-27 22:08 UTC (History)
14 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tomas Mysik 2008-10-13 15:30:47 UTC
java.lang.AssertionError
        at 
org.netbeans.modules.php.project.ui.customizer.RunAsValidator.validateUploadDirectory(RunAsValidator.java:98)
        at 
org.netbeans.modules.php.project.ProjectPropertiesSupport.validateActiveConfig(ProjectPropertiesSupport.java:177)
        at 
org.netbeans.modules.php.project.ProjectPropertiesSupport.isActiveConfigValid(ProjectPropertiesSupport.java:145)
        at 
org.netbeans.modules.php.project.ui.actions.Command.isRunConfigurationValid(Command.java:272)
        at 
org.netbeans.modules.php.project.ui.actions.FtpCommand.invokeAction(FtpCommand.java:91)
        at 
org.netbeans.modules.php.project.PhpActionProvider.invokeAction(PhpActionProvider.java:102)
        at 
org.netbeans.modules.project.ui.actions.ProjectAction.actionPerformed(ProjectAction.java:129)
        at 
org.netbeans.modules.project.ui.actions.LookupSensitiveAction.actionPerformed(LookupSensitiveAction.java:161)
        at 
javax.swing.AbstractButton.fireActionPerformed(AbstractButton.java:1995)
        at 
javax.swing.AbstractButton$Handler.actionPerformed(AbstractButton.java:2318)
        at 
javax.swing.DefaultButtonModel.fireActionPerformed(DefaultButtonModel.java:387)
        at 
javax.swing.DefaultButtonModel.setPressed(DefaultButtonModel.java:242)
        at javax.swing.AbstractButton.doClick(AbstractButton.java:357)
        at 
javax.swing.plaf.basic.BasicMenuItemUI.doClick(BasicMenuItemUI.java:1225)
        at 
javax.swing.plaf.basic.BasicMenuItemUI$Handler.mouseReleased(BasicMenuItemUI.java:1266)
        at java.awt.Component.processMouseEvent(Component.java:6134)
        at javax.swing.JComponent.processMouseEvent(JComponent.java:3265)
        at java.awt.Component.processEvent(Component.java:5899)
        at java.awt.Container.processEvent(Container.java:2023)
        at java.awt.Component.dispatchEventImpl(Component.java:4501)
        at java.awt.Container.dispatchEventImpl(Container.java:2081)
        at java.awt.Component.dispatchEvent(Component.java:4331)
        at 
java.awt.LightweightDispatcher.retargetMouseEvent(Container.java:4301)
        at 
java.awt.LightweightDispatcher.processMouseEvent(Container.java:3965)
        at java.awt.LightweightDispatcher.dispatchEvent(Container.java:3895)
        at java.awt.Container.dispatchEventImpl(Container.java:2067)
        at java.awt.Window.dispatchEventImpl(Window.java:2458)
        at java.awt.Component.dispatchEvent(Component.java:4331)
        at java.awt.EventQueue.dispatchEvent(EventQueue.java:599)
        at 
org.netbeans.core.TimableEventQueue.dispatchEvent(TimableEventQueue.java:104)
[catch] at 
java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:269)
        at 
java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:184)
        at 
java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:174)
        at 
java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:169)
        at 
java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:161)
        at java.awt.EventDispatchThread.run(EventDispatchThread.java:122)
Comment 1 Tomas Mysik 2008-10-13 17:42:32 UTC
This happens if Upload Directory in project customizer is not defined.
(Probably a good candidate for patch for NB 6.5.)
Comment 2 Tomas Mysik 2008-10-16 10:24:44 UTC
Fixed.
http://hg.netbeans.org/main/rev/c425394afa87
Comment 3 Quality Engineering 2008-10-16 15:41:52 UTC
Integrated into 'main-golden', will be available in build *200810161401* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/c425394afa87
User: Tomas Mysik <tmysik@netbeans.org>
Log: #149958: AssertionError in RunAsValidator.validateUploadDirectory(RunAsValidator.java:98)
Comment 4 Tomas Mysik 2008-10-22 15:54:12 UTC
*** Issue 151024 has been marked as a duplicate of this issue. ***
Comment 5 Tomas Mysik 2008-11-18 16:45:15 UTC
*** Issue 152565 has been marked as a duplicate of this issue. ***
Comment 6 Mikhail Matveev 2008-11-18 17:26:47 UTC
Verified
Comment 7 pgebauer 2008-11-19 15:20:04 UTC
The fix has been ported into the release65_fixes repository.

http://hg.netbeans.org/release65_fixes/rev/fb73e8c74d1b

Comment 8 Exceptions Reporter 2008-11-20 13:54:09 UTC
Reopening - reproduced in NetBeans IDE 6.5 (Build 200811131701)
http://statistics.netbeans.org/exceptions/detail.do?id=140615
Comment 9 Exceptions Reporter 2008-11-20 13:56:07 UTC
Reopening - reproduced in NetBeans IDE 6.5 (Build 200811100001)
http://statistics.netbeans.org/exceptions/detail.do?id=140617
Comment 10 hneufeld 2008-11-20 14:09:34 UTC
In 6.5, this can be fixed for my PHP projects by deleting and recreating the project.  The error occurs when working
with any project created under several 6.5 beta releases, but not under projects created with the final release.
Comment 11 Tomas Mysik 2008-11-20 14:12:18 UTC
Fixed in trunk; exception report was from FCS, revision http://hg.netbeans.org/release65/rev/76d51071af8a.
(No such revision exists in trunk.)
Comment 12 Jan Horvath 2008-11-20 14:20:45 UTC
this issue should not be reopened
Comment 13 Tomas Mysik 2008-11-20 14:27:17 UTC
> In 6.5, this can be fixed for my PHP projects by deleting and recreating the project.  The error occurs when working
> with any project created under several 6.5 beta releases, but not under projects created with the final release.

Even easier work around is to set Project Upload Directory to "/".
Comment 14 amahdy 2009-01-06 14:28:22 UTC
I had the last 6.5 Release, opened a new PHP project with exciting source, then chooses "upload" and I got this issue,
though; when creating a NEW PHP project [only], and choose upload it works perfectly...

-> the FTP defaults to "www", there are FTP's without "www" folder in them ...
-> there should be a shortcut key to upload the current file ...
Comment 15 pgebauer 2009-01-06 14:56:23 UTC
amahdy, have you also applied 65patch1? The info about the patch is available at http://wiki.netbeans.org/NetBeans6.5PatchesInfo . Steps how to update 
your IDE are at 
http://hg.netbeans.org/main/raw-file/63c0534adb36/usersguide/javahelp/org/netbeans/modules/usersguide/configure/modules/autoupdate.html .
The correct version of PHP plugin in your IDE after successful update should be 1.2.2 . Could you please check it?

Comment 16 Tomas Mysik 2009-02-13 09:41:08 UTC
No response for a long time, so closing as FIXED again. Feel free to reopen and provide information we asked for. Thanks a lot for
reporting.
Comment 17 amahdy 2009-02-13 15:33:40 UTC
Oh yea the issue was fixed after updating the PHP-plugin, even the version now is 1.2.3 ... Thanks!
[ as feature request only: a shortcut to upload current file ]


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo