Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 149914 - No "Test" option for EJB project
No "Test" option for EJB project
Status: VERIFIED FIXED
Product: javaee
Classification: Unclassified
Component: EJB Project
6.x
All All
: P3 (vote)
: 6.x
Assigned To: David Konecny
issues@javaee
65fixes1-verified
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-13 09:25 UTC by witoldsz
Modified: 2009-02-19 20:58 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description witoldsz 2008-10-13 09:25:50 UTC
Hello,
I have EJB project, it has "Test Packages" node in project view. When I right click on this project, there is no "Test
Alt+F6" option like in my libraries projects, so I have to open and manually execute my test classes for EJBs :/

I have just created new project to see if this is not a problem with the project itself, but new project with test class
does not have this option as well.
Comment 1 David Konecny 2008-10-13 21:51:21 UTC
The action is not available in project's popup menu and that should be fixed. Thanks. But action does exist. Use
directly ALT+F6 shortcut or top level menu Run->Test Project. 
Comment 2 witoldsz 2008-10-13 22:07:37 UTC
Thanks for the info. I have forgotten there is "Test project" in 'run' main menu.
The only thing that bothers me is why target milestone was set to 7.0? The bug really looks like it could be fixed in...
hmmm. one, two, maybe few lines of code or maybe just a tiny fix in System Filesystem registry, which could be grabbed
by auto-update for everyone using NB 6.0, 6.1, 6.5 beta (maybe even 5.x). 
Why waiting beyond next release?
Comment 3 David Konecny 2008-10-13 22:33:26 UTC
It is copy&paste of one line of code. Multiplied by 3 (Web and AppClient project needs to be fixed as well).

The problem is timing. 6.5 in now in High Resistence mode - only P1 and nasty P2 should be fixed and included in
release. Everything else is going to be 7.0 and possibly 6.5 patch releases.
Comment 4 witoldsz 2008-10-13 23:03:20 UTC
If I could tell to my customer: yes, Mr. X, I could fix that in just _few_secounds_, but our policy /bla bla bla/...
just wait few months, maybe one year and I will release a fix for you...

Isn't that ridiculous? I can understand new release is in final stage, no P1 bugs can be left before release, but does
it really automatically means you cannot patch P3 issues, even if they would occupy no more than one minute of a
developer work? Is it The Quality of NetBeans software? How can I be sure, there are no more stupid issues like this all
around in NetBeans which are identified, the solution is known, but no one is willing to release patch? Maybe next time
I will spend like one hour describing some bug just to get an answer: "yes dude, we know this for long time, but we are
not going to release a fix until next major release..." aaargh... 

And what about 6.1, 6.0? Are they abandoned?
Comment 5 David Konecny 2008-10-14 11:00:02 UTC
I'm sorry you feel frustrated about this. NB development processes have established over the years and represent what we
think is the best way to release our product. Any ideas for improvements are always welcome. Preferably on a mailing
list to reach wider audience.

Re. "does it really automatically means you cannot patch P3 issues" - yes. Purpose of high resistence mode is to
minimize changes to your code base to minimum to prevent last minute regressions and to give QA a window for final
testing. Only the absolutely necessary fixes get through after careful review and testing. IMO that's a good thing. Fix
of this issue is trivial and 98% regression free (depends on level of your paranoia) but on the other hand it is a P3
and product can be released with this defect without huge impact on a user and a patch release can be provided within
weeks after release. With any release you are juggling with time, resources and quality and there always will be a
compromise. It would be actually boring to live in a perfect world where everything is unlimited and you do not have to
compromise, wouldn't it?

Re. "next time I will spend like one hour describing some bug" - it is highly appreciated! Seriously. NB is not a small
project and we do need processes in place. If you let fifty developers fix issues till the release day you are putting
quality of final product in a danger because QA will never have a time to test it properly. This change requires
actually a UI change (new action in project's popup menu) and UI freeze has happened about month ago. Again, to minimize
amount of UI changes and give localization and documentation team time to do their job. There is a process for late UI
changes and if we discovered this issue two weeks ago we could still fix it.

Re. "And what about 6.1, 6.0" - there were about four or five patch releases for 6.1 so far. There is a process how to
make an issue candidate for a patch (see http://wiki.netbeans.org/NetBeans6.1PatchesInfo ).

I want to reiterate that your time filling this issue is highly appreciated and will help improve NB. Thanks, David.
Comment 6 pslechta 2008-10-16 14:34:54 UTC
Hello witoldsz,

as you can see (Status whiteborad field), this issue was marked as candidate for NB 6.5 patch 1 and thus is on the radar
of sustaining group. If everything goes fine, the fix will be part of NB 6.5 patch 1 which should be released in 4-5
weeks after final version of NB 6.5.

Thank you for reporting the issue and for your patience!

NB Sustaining team
Comment 7 pgebauer 2008-10-16 15:40:12 UTC
Hello witoldsz,

the plan for free proactive patches is to release module updates for the latest version of NetBeans IDE every 4-5 weeks
after the IDE release until 4-5 weeks before the next NetBeans IDE release. We did it in the past and we are going to
continue with that for NetBeans IDE 6.5. If the plan wasn't sufficient for you, you could purchase Sun service plan
contract for NetBeans. It allows you to escalate your issues and you will get fixed modules independently on 4-5 weeks
cycle. Of course, older NetBeans IDE versions like 5.5.1 or 6.0 are supported as well.

For more information on purchasing a Sun service plan contract for NetBeans, refer to the two service plan items in the
Sun Service table found on our NetBeans Support Resources page http://www.netbeans.org/kb/support.html
Comment 8 David Konecny 2008-10-16 22:37:13 UTC
Fixed locally for web and ejb project as 60949ca2e995. AppClient project already has the action in its popup menu. Ear
does not have tests and therefore does not need to have the action.
Comment 9 witoldsz 2008-10-17 15:38:18 UTC
Thaks pgebauer for explanation about how does it all works in NetBeans project. It means once you release a new version,
or when the new version is on the horizon (like 6.5 right now) the old one is not updated (at least not that often).

I was not aware one can purchase a service plan for NetBeans from Sun.

Regards,
Witold Szczerba
Comment 10 pgebauer 2008-10-17 16:05:19 UTC
Yes, your comprehension is correct. I'm looking forward to hearing from you regarding an escalation. ;-)

Regards,
PetrG
Comment 11 witoldsz 2008-10-17 16:31:43 UTC
I am wondering: if I did not know about the paid service plan for NetBeans, maybe hundreds, thousands of NB users does
not know it as well... and are not considering it. Maybe that would be good idea for something like MyNetBeans (like
MyEclipse) where you pay and demand instead of "it is free: use it and do not complain or help us".
Comment 12 Quality Engineering 2008-10-20 04:03:37 UTC
Integrated into 'main-golden', will be available in build *200810200201* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/60949ca2e995
User: David Konecny <dkonecny@netbeans.org>
Log: #149914 - No "Test" option for EJB/Web project
Comment 13 pslechta 2008-11-20 14:42:50 UTC
Please verify this issue so it can be part of NB 6.5 patch 1.
Comment 14 Lukas Jungmann 2008-11-21 17:21:34 UTC
v. in (custom) trunk
Comment 15 pslechta 2008-11-21 20:07:12 UTC
The fix was ported into release65_fixes repository.

http://hg.netbeans.org/release65_fixes/rev/f3f3900345e5


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo