Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 149876 - Hibernate named queries
Hibernate named queries
Status: RESOLVED WONTFIX
Product: javaee
Classification: Unclassified
Component: Hibernate
6.x
All All
: P3 (vote)
: TBD
Assigned To: Vadiraj Deshpande
issues@javaee
:
: 149877 153967 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-11 21:13 UTC by javydreamercsw
Modified: 2016-07-07 08:52 UTC (History)
0 users

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description javydreamercsw 2008-10-11 21:13:16 UTC
First of all sorry if this is not well placed but I couldn't find a proper category. I kind of remember a persistece
category or even Hibernate...

Anyways, I noticed that the Hibernate support doesn't create named queries when creating mapping files from database as
Persistence support does.

Isn't the same thing?

I think this should be added.
Comment 1 Peter Pis 2008-10-11 23:08:30 UTC
*** Issue 149877 has been marked as a duplicate of this issue. ***
Comment 2 Peter Pis 2008-10-11 23:12:00 UTC
Reassigning to web.
Comment 3 Vadiraj Deshpande 2008-10-12 16:24:30 UTC
As of now Hibernate support in NetBeans 6.5 (daily builds) does not support creating new named queries.
However, you can create and use them manually.
Marking as feature.
Comment 4 Vadiraj Deshpande 2009-01-20 10:19:45 UTC
*** Issue 153967 has been marked as a duplicate of this issue. ***
Comment 5 Vadiraj Deshpande 2009-01-20 10:21:41 UTC
As part of this enhancement to support Named Queries in Mapping files, refactoring of POJOs need to be enhanced to
update the POJO names included in the named queries in mapping files.
(http://web.netbeans.org/issues/show_bug.cgi?id=153967)
Comment 6 malfunction84 2009-01-20 15:13:42 UTC
Renaming a class already refactors class names used in @NamedQuery annotations, right?
Comment 7 javydreamercsw 2009-12-25 19:38:14 UTC
Not it doesn't. I always need to change those manually.
Comment 8 javydreamercsw 2010-09-27 15:42:13 UTC
Changing to TBD as it clearly mised the 6.9 release
Comment 9 Martin Balin 2016-07-07 08:52:58 UTC
This old bug may not be relevant anymore. If you can still reproduce it in 8.2 development builds please reopen this issue.

Thanks for your cooperation,
NetBeans IDE 8.2 Release Boss


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo