Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 149788 - reflect.UndeclaredThrowableException at $Proxy5.propertyChange
reflect.UndeclaredThrowableException at $Proxy5.propertyChange
Status: VERIFIED FIXED
Product: javaee
Classification: Unclassified
Component: Web Project
6.x
All All
: P3 (vote)
: 6.x
Assigned To: Trey Spiva
issues@javaee
http://statistics.netbeans.org/except...
EXCEPTIONS_REPORT, 65fixes2-verified
:
: 149718 150122 151975 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-10 16:39 UTC by Tomas Danek
Modified: 2009-02-19 23:26 UTC (History)
6 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (17.31 KB, text/plain)
2008-10-10 16:39 UTC, Tomas Danek
Details
stacktrace (19.02 KB, text/plain)
2008-11-05 07:16 UTC, Exceptions Reporter
Details
stacktrace (15.86 KB, text/plain)
2008-12-07 10:38 UTC, Maksim Khramov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Tomas Danek 2008-10-10 16:39:14 UTC
Build: NetBeans IDE Dev (Build 200810100201)
VM: Java HotSpot(TM) Client VM, 11.0-b11, Java(TM) SE Runtime Environment, 1.6.0_10-beta-b14
OS: Linux, 2.6.24-19-generic, i386

User Comments:
musilt2: resolving misssing server problem. Root cause is the ISE-  Potentional deadlock PM.mutex() vs Children.MUTEX.



Stacktrace: 
java.lang.reflect.UndeclaredThrowableException
        at $Proxy.propertyChange(.java:0)
        at org.openide.nodes.Node.fireOwnPropertyChange(Node.java:1206)
        at org.openide.nodes.Node.fireIconChange(Node.java:1027)
        at org.openide.nodes.FilterNode$NodeAdapter.propertyChange(FilterNode.java:1207)
        at org.openide.nodes.FilterNode$NodeAdapter.propertyChange(FilterNode.java:1170)
        at org.openide.nodes.Node.fireOwnPropertyChange(Node.java:1206)
Comment 1 Tomas Danek 2008-10-10 16:39:20 UTC
Created attachment 71566 [details]
stacktrace
Comment 2 David Konecny 2008-10-12 23:08:38 UTC
Should be fixed in web area similarly as issue 148926.
Comment 3 David Konecny 2008-10-15 22:11:10 UTC
*** Issue 150122 has been marked as a duplicate of this issue. ***
Comment 4 David Konecny 2008-10-16 23:16:05 UTC
Fixed locally as 99b0832dbd35.
Comment 5 Quality Engineering 2008-10-20 04:02:56 UTC
Integrated into 'main-golden', will be available in build *200810200201* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/99b0832dbd35
User: David Konecny <dkonecny@netbeans.org>
Log: #149788 - IllegalStateException: Should not acquire Children.MUTEX while holding ProjectManager.mutex()
Comment 6 David Konecny 2008-10-28 20:53:16 UTC
*** Issue 149718 has been marked as a duplicate of this issue. ***
Comment 7 David Konecny 2008-11-02 21:23:16 UTC
*** Issue 151975 has been marked as a duplicate of this issue. ***
Comment 8 Exceptions Reporter 2008-11-05 07:16:16 UTC
Build: NetBeans IDE Dev (Build 200810031942)
VM: Java HotSpot(TM) Client VM, 1.6.0-b105, Java(TM) SE Runtime Environment, 1.6.0-b105
OS: Windows Vista, 6.0, x86

User Comments: 


Stacktrace: 
java.lang.reflect.UndeclaredThrowableException
        at $Proxy.propertyChange(.java:0)
        at org.openide.nodes.Node.fireOwnPropertyChange(Node.java:1206)
        at org.openide.nodes.Node.fireIconChange(Node.java:1027)
        at org.openide.nodes.FilterNode$NodeAdapter.propertyChange(FilterNode.java:1207)
        at org.openide.nodes.FilterNode$NodeAdapter.propertyChange(FilterNode.java:1170)
        at org.openide.nodes.Node.fireOwnPropertyChange(Node.java:1206)
Comment 9 Exceptions Reporter 2008-11-05 07:16:27 UTC
Created attachment 73269 [details]
stacktrace
Comment 10 Exceptions Reporter 2008-11-12 09:10:36 UTC
Reopening - reproduced in NetBeans IDE Dev (Build 200811120201)
http://statistics.netbeans.org/exceptions/detail.do?id=138651
Comment 11 David Konecny 2008-11-12 18:52:20 UTC
The fix from web/project should be applied to other project types: EjbJarLogicalViewProvider in case of latest report
but possibly to others (appclient, ear)
Comment 12 pgebauer 2008-11-24 09:31:19 UTC
The issue didn't pass the nomination process by nomination cut-off date. It has been marked as 65fixes2-candidate.
Comment 13 Maksim Khramov 2008-12-07 10:38:32 UTC
Build: NetBeans IDE Dev (Build 200811071401)
VM: Java HotSpot(TM) Client VM, 11.0-b15, Java(TM) SE Runtime Environment, 1.6.0_10-rc-b28
OS: Windows XP, 5.1, x86

User Comments: 


Stacktrace: 
java.lang.reflect.UndeclaredThrowableException
        at $Proxy5.propertyChange(.java:0)
        at org.openide.nodes.Node.fireOwnPropertyChange(Node.java:1213)
        at org.openide.nodes.Node.fireIconChange(Node.java:1027)
        at org.openide.nodes.FilterNode$NodeAdapter.propertyChange(FilterNode.java:1208)
        at org.openide.nodes.FilterNode$NodeAdapter.propertyChange(FilterNode.java:1171)
        at org.openide.nodes.Node.fireOwnPropertyChange(Node.java:1213)
Comment 14 Maksim Khramov 2008-12-07 10:38:39 UTC
Created attachment 74658 [details]
stacktrace
Comment 15 Trey Spiva 2008-12-09 22:39:13 UTC
Fixed

http://hg.netbeans.org/main/rev/23f3f813b8d3
Comment 16 Tomas Danek 2009-01-12 12:50:29 UTC
verified in 20090108 (scenario with missing server)
Comment 17 jinb 2009-01-14 15:24:45 UTC
fix backported into release65_fixes branch
http://hg.netbeans.org/release65_fixes/rev/4c317bd0b37b


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo