Bug 149736 - Breakpoints do not work on Mac if OutputWindow is used
Breakpoints do not work on Mac if OutputWindow is used
Status: VERIFIED FIXED
Product: cnd
Classification: Unclassified
Component: Debugger
6.x
Macintosh (x86) Mac OS X
: P2 (vote)
: 6.x
Assigned To: Egor Ushakov
issues@cnd
65fixes2-verified
:
: 151005 151237 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-10 11:35 UTC by Alexander Pepin
Modified: 2009-06-25 10:59 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
gdb log (2.18 KB, text/plain)
2008-10-10 11:36 UTC, Alexander Pepin
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alexander Pepin 2008-10-10 11:35:43 UTC
Steps to reproduce:
- create Arguments sample
- set a line BP
- start debugger, it stops at BP
- stop debugger
- set 'console type' to 'Output Window'
- start debugger
Result: Debugger starts but does not stop at BP and does not finish at the same time. So it gets into 'unknown' state,
however it can be finished by clicking on 'Finish debug session' button.
Comment 1 Alexander Pepin 2008-10-10 11:36:40 UTC
Created attachment 71536 [details]
gdb log
Comment 2 Alexander Pepin 2008-10-22 14:57:59 UTC
*** Issue 151005 has been marked as a duplicate of this issue. ***
Comment 3 Alexander Pepin 2008-10-22 15:00:39 UTC
added from issue #151005
The problem is that for some reason gdb on mac fails on
stream redirection:
109-exec-run < /tmp/gdbFifo0.fifo > /tmp/gdbFifo1.fifo 2>&1
109^error

I was unable to reproduce it in standalone gdb.
Comment 4 Alexander Pepin 2008-10-27 14:24:53 UTC
*** Issue 151237 has been marked as a duplicate of this issue. ***
Comment 5 Egor Ushakov 2008-10-28 12:54:41 UTC
There is no safe fix for 6.5.
Workaround is to use external terminal.
This bug does not affect remote debugging on Linux and Solaris only on Mac.
Comment 6 Egor Ushakov 2008-12-11 13:08:27 UTC
fixed in the changeset:
http://hg.netbeans.org/main/rev/b5137dbfe8ef
Comment 7 Alexander Pepin 2008-12-12 14:38:37 UTC
not included into build 200812120201 but verified with a new org-...-debugger-gdb.jar 
Comment 8 Alexander Pepin 2008-12-15 13:55:41 UTC
verified in build 200812150201
Comment 9 jinb 2009-01-07 19:22:30 UTC
fix backported into release65_fixes branch
http://hg.netbeans.org/release65_fixes/rev/eae4f38c9fd7
Comment 10 Alexander Pepin 2009-01-19 18:53:42 UTC
verified in patch2


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo