Bug 149712 - xdebug port is occupied problem
xdebug port is occupied problem
Status: RESOLVED FIXED
Product: php
Classification: Unclassified
Component: Debugger
6.x
PC All
: P3 with 1 vote (vote)
: 6.x
Assigned To: rmatous
issues@php
:
: 154092 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-10 07:49 UTC by dimis283
Modified: 2009-03-12 15:30 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description dimis283 2008-10-10 07:49:56 UTC
I change my windows platform to vista from xp.
So after 1-2 times of debugging an alert "9000 port is occupied" was there.
I change the port via php.ini etc and it was ok but not for a long time, the new port had the same problem.
It was the same for all port number I changed, that port were occupied.
I write a php shop with codeigniter.I do not know what is wrong.
NetBeans IDE Dev (Build 200810090201) is the last download with the problem.
Dimis
Comment 1 rmatous 2008-10-10 11:38:04 UTC
Not reproducible for me, I'm going to investigate more deeply. For the time being, please, could you try to find, what
is using the port?

I use this command on Linux:
watch 'netstat -nplta | grep 9000'

You could try something similar on windows and please let me know.

Would be also nice to get more info, you could put into your php.ini  setting like this:
xdebug.remote_log=/tmp/xdebug.log (see http://www.xdebug.org/docs/all_settings) and restart apache server.
FYI - xdebug.remote_log setting allows you to log debugger communication.
Comment 2 rmatous 2008-10-13 10:49:49 UTC
Users' comments:
> The error was triggered only when I used the IE7 and produced an event which ran into a breakpoint. When I did this
for > a second time I got the error message that the port 9000 was already in use.

> With FF3 everything works as expected. 

(other user)
> For me too that problem is with IE.

So, seems that NEEDS to be EVALUATED with IE7



Comment 3 rmatous 2008-12-09 15:20:11 UTC
*** Issue 154092 has been marked as a duplicate of this issue. ***
Comment 4 rmatous 2008-12-09 15:24:29 UTC
tested on Vista with IE7 && FF - both worked for me

Please, I would need help - if you reproduce this issue, please try to find out why the port is occupied (see my comment
from Oct 10)
Comment 5 pkirkaas 2008-12-18 14:24:04 UTC
I have the same problem with the ports; works for a few times, then gets the port occupied message.  Rebooting &
restarting doesn't help.  I use XPsp2 & Firefox 3, the latest updated netbeans 6.5.  

Xdebug DOES work with Eclipse & the xdebug gui client.  But of course when I test with netbeans, it is after a clean
reboot,, with neither of those other applications running.

I did the netstat test using cigwin.  With netbeans running, after trying to debug & receiving the error, the result is:

netstat:   TCP    0.0.0.0:9000           0.0.0.0:0              LISTENING       1592
ps: 1592       0       0       1592    ?    0 13:10:46 E:\Program Files\Java\jdk1.6.0_10\jre\bin\java.exe

INTERESTINGLY:  When I shut down netbeans, netstat returns the same; process 1592 still listening on port 9000;
BUT: java.exe & PID 1592 no longer appears in either ps -aW OR in the Windows Task Manager.  So maybe some windows issue
failing to deregister a listner?  I don't know.  Any thoughts?  I'd be happy to perform any additional tests to clarify
this issue.

Comment 6 rmatous 2009-03-12 15:29:39 UTC
I can't reproduce but I tried to rewrite relevant piece of code and did some relevant changes like: keep port 9000 for
the whole dbg session (so no need to reopen it many times), checked closing port, synchronization, deamon threads &&
others - I hope this issue to be fixed for M3

Please, verify or reopen, thanks


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo