Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 149586 - [65cat] New database connection requires the database specified
[65cat] New database connection requires the database specified
Status: RESOLVED DUPLICATE of bug 150660
Product: db
Classification: Unclassified
Component: Code
6.x
PC Windows XP
: P3 (vote)
: 6.x
Assigned To: David Vancouvering
issues@db
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-09 05:53 UTC by yudiset
Modified: 2008-11-13 19:50 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
New database connection dialog (53.17 KB, image/jpeg)
2008-10-10 04:43 UTC, yudiset
Details

Note You need to log in before you can comment on or make changes to this bug.
Description yudiset 2008-10-09 05:53:18 UTC
[ BUILD # : 200810080330 ]
[ JDK VERSION : 1.6.0_07 ]

Using another tool to connect to a MySQL server such as SQLYog
(www.webyog.com), we can connect to a MySQL server without have to
specify a database.

Also in reality, we don't always have the knowledge of the existing
databases in a MySQL server.

Selection of a database when connecting to a MySQL server should be
an option.
Comment 1 Roman Mostyka 2008-10-09 12:27:25 UTC
You can register MySQL server and then expand it's node and You'll see all existing databases and connect to every of
them. Or this way doesn't fit You for some reason?
Comment 2 Roman Mostyka 2008-10-09 12:28:23 UTC
You can register MySQL server and then expand it's node and You'll see all existing databases and connect to every of
them. Or this way doesn't fit You for some reason?
Comment 3 yudiset 2008-10-10 04:43:08 UTC
Created attachment 71524 [details]
New database connection dialog
Comment 4 yudiset 2008-10-10 04:45:47 UTC
Sorry, for not being specific enough.
What I meant was the first time we need to register/connect to a MySQL server.
(on the Services tab, we right click on a MySQL node and then Connect Using)

I attached the screenshot.
Comment 5 John Baker 2008-10-10 05:42:27 UTC
In NetBeans, by starting MySQL, you are connected without specifying a database.  Maybe just the terminology differs.

If you want to connect to a database but don't know the databases available:
1) Start MySQL 
2) Expand the MySQL node
3) Select a database, right-click then choose Connect...

Comment 6 John Baker 2008-10-10 06:05:01 UTC
correction, once you start MySQL, there is a Connect menuitem under the MySQL node.  Once choosing Connect,  then you
are connected without specifying a database
Comment 7 David Vancouvering 2008-10-10 07:27:20 UTC
I agree you should be able to connect without specifying a database, I think this is a bug.

As a workaround, you can click on Direct URL entry and type in "jdbc:mysql://<host>:<port>/"

David
Comment 8 yudiset 2008-10-10 11:18:02 UTC
@jbaker:
I forgot to add the Drivers node.
So what I meant is: on the Services tab - Drivers - we right click on a MySQL node and then Connect Using.

@davidvc:
Your suggested temporary solution works.
Just want to add, when using the standard port (3306), we can just use "jdbc:mysql://<host>/".
Thanks very much for the workaround.
Comment 9 David Vancouvering 2008-11-13 19:50:40 UTC
We are planning to do some changes in this release to (a) make it possible to browse directly to tables from the MySQL
node and (b) list all schemas (aka databases) that the connecting user has rights to view from any connection. 

I'm marking this a duplicate of issue 150660 (browse directly to tables from MySQL node), since implementing this
feature will fix this bug.

*** This issue has been marked as a duplicate of 150660 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo