Bug 149564 - org.netbeans.modules.spring classes are loaded during NetBeans startup with LimeWire project
org.netbeans.modules.spring classes are loaded during NetBeans startup with L...
Status: RESOLVED WONTFIX
Product: javaee
Classification: Unclassified
Component: Spring
6.x
PC Windows XP
: P4 (vote)
: 6.x
Assigned To: issues@javaee
issues@javaee
http://wiki.netbeans.org/FitnessViaWh...
: PERFORMANCE, TEST
Depends on: 150194
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-08 20:47 UTC by Alexander Kouznetsov
Modified: 2016-07-07 08:53 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
Stacktraces (23.39 KB, text/plain)
2008-10-08 20:48 UTC, Alexander Kouznetsov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alexander Kouznetsov 2008-10-08 20:47:39 UTC
Performance whitelist test reports that following classes are loaded during NetBeans startup with LimeWire project:

org.netbeans.modules.spring.beans.ProjectLookupProvider
org.netbeans.modules.spring.beans.ProjectLookupProvider$Kind
org.netbeans.modules.spring.beans.ProjectSpringScopeProvider
org.netbeans.modules.spring.beans.RecommendedTemplatesImpl
org.netbeans.modules.spring.beans.SpringConfigFileLocationProviderImpl
org.netbeans.modules.spring.beans.jumpto.GoToBeanAction
org.netbeans.modules.spring.spi.beans.SpringConfigFileLocationProvider

Please don't load these classes unless they are really necessary. More information about the test available via the URL
specified.

Comment from jtulach: 
I do not like these classes, probably P3 bug for next release. However I 
understand that there is a missing API in project extender to allow 
declarative extensibility without instantiating the classes.
Comment 1 Alexander Kouznetsov 2008-10-08 20:48:05 UTC
Created attachment 71415 [details]
Stacktraces
Comment 2 Andrei Badea 2008-10-14 10:20:47 UTC
Not a bug. I don't know a way to extend the project lookup without loading classes.
Comment 3 Alexander Kouznetsov 2008-10-21 20:58:42 UTC
Please reassign the bug to the appropriate component/subcomponent for evaluation.
Comment 4 Andrei Badea 2008-10-24 19:05:47 UTC
Adding dependency.
Comment 5 Alexander Kouznetsov 2008-10-25 10:41:27 UTC
The issue is still valid.
Comment 6 Andrei Badea 2008-10-27 18:54:33 UTC
Sorry, I didn't mean to close as invalid in desc5. I still maintain the priority though.
Comment 7 Martin Balin 2016-07-07 08:53:28 UTC
This old bug may not be relevant anymore. If you can still reproduce it in 8.2 development builds please reopen this issue.

Thanks for your cooperation,
NetBeans IDE 8.2 Release Boss


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo