Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 149563 - org.netbeans.spi.server.ServerInstanceProvider is loaded during NetBeans startup with LimeWire project
org.netbeans.spi.server.ServerInstanceProvider is loaded during NetBeans star...
Status: VERIFIED DUPLICATE of bug 148177
Product: serverplugins
Classification: Unclassified
Component: GlassFish
6.x
PC Windows XP
: P3 (vote)
: TBD
Assigned To: _ pcw
issues@serverplugins
http://wiki.netbeans.org/FitnessViaWh...
: PERFORMANCE, TEST
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-08 20:33 UTC by Alexander Kouznetsov
Modified: 2008-10-09 09:57 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
Stacktraces (6.88 KB, text/plain)
2008-10-08 20:33 UTC, Alexander Kouznetsov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alexander Kouznetsov 2008-10-08 20:33:08 UTC
Performance whitelist test reports that following classes are loaded during NetBeans startup with LimeWire project:

org.netbeans.spi.server.ServerInstanceProvider

Please don't load these classes unless they are really necessary. More information about the test available via the URL
specified.

Comment from jtulach: 
Called from: 
org.netbeans.modules.glassfish.spi.ServerUtilities.getServerProvider(ServerUtilities.java:167)          
org.netbeans.modules.glassfish.javaee.Hk2OptionalFactory.finishServerInitialization(Hk2OptionalFactory.java:268)
Imho it is not OK to "finishServerInitialization" during start of non web 
project.
Comment 1 Alexander Kouznetsov 2008-10-08 20:33:39 UTC
Created attachment 71412 [details]
Stacktraces
Comment 2 Petr Hejl 2008-10-08 20:37:38 UTC

*** This issue has been marked as a duplicate of 148177 ***
Comment 3 Alexander Kouznetsov 2008-10-09 09:57:42 UTC
verified


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo