Bug 149084 - SuiteLogicalView$SuiteRootNode.propertyChange should fire name changes later
SuiteLogicalView$SuiteRootNode.propertyChange should fire name changes later
Status: RESOLVED FIXED
Product: apisupport
Classification: Unclassified
Component: Project
6.x
All All
: P2 (vote)
: 6.x
Assigned To: rmichalsky
issues@apisupport
http://statistics.netbeans.org/except...
EXCEPTIONS_REPORT
: THREAD
: 148980 149342 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-03 15:44 UTC by Lukas Hasik
Modified: 2008-10-09 05:57 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (16.63 KB, text/plain)
2008-10-03 15:44 UTC, Lukas Hasik
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Lukas Hasik 2008-10-03 15:44:42 UTC
Build: NetBeans IDE Dev (Build 081002)
VM: Java HotSpot(TM) Client VM, 1.5.0_14-b03, Java(TM) 2 Runtime Environment, Standard Edition, 1.5.0_14-b03
OS: Windows XP, 5.1, x86

Stacktrace: 
java.lang.reflect.UndeclaredThrowableException
        at $Proxy.propertyChange(.java:0)
        at org.openide.nodes.Node.fireOwnPropertyChange(Node.java:1206)
        at org.openide.nodes.FilterNode$NodeAdapter.propertyChange(FilterNode.java:1195)
        at org.openide.nodes.FilterNode$NodeAdapter.propertyChange(FilterNode.java:1170)
        at org.openide.nodes.Node.fireOwnPropertyChange(Node.java:1206)
        at org.openide.nodes.Node.fireNameChange(Node.java:1005)
Comment 1 Lukas Hasik 2008-10-03 15:44:46 UTC
Created attachment 71123 [details]
stacktrace
Comment 2 Lukas Hasik 2008-10-03 15:51:29 UTC
exception appeared when I added another cluster&module to my suite
Comment 3 Jesse Glick 2008-10-03 16:44:12 UTC
Potential source of deadlocks.
Comment 4 rmichalsky 2008-10-06 14:01:47 UTC
Info from Tomas: calls to nodes should be made outside of ProjectManager.mutex (via invokeLater or RP)
Comment 5 Milan Kubec 2008-10-06 15:02:38 UTC
*** Issue 148980 has been marked as a duplicate of this issue. ***
Comment 6 Tomas Danek 2008-10-07 10:57:13 UTC
*** Issue 149342 has been marked as a duplicate of this issue. ***
Comment 7 rmichalsky 2008-10-08 12:47:47 UTC
fixed in core-main #eaebd48599b8
Comment 8 Quality Engineering 2008-10-09 05:57:26 UTC
Integrated into 'main-golden', will be available in build *200810090201* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/eaebd48599b8
User: Richard Michalsky <rmichalsky@netbeans.org>
Log: #149084, #149080: calls to nodes must be made outside of ProjectManager.mutex


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo