Bug 149080 - UnitTestLibrariesNode$LibrariesChildren should set keys asynch
UnitTestLibrariesNode$LibrariesChildren should set keys asynch
Status: RESOLVED FIXED
Product: apisupport
Classification: Unclassified
Component: Project
6.x
All All
: P2 (vote)
: 6.x
Assigned To: rmichalsky
issues@apisupport
http://statistics.netbeans.org/except...
EXCEPTIONS_REPORT
: THREAD
: 149357 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-03 15:14 UTC by Lukas Hasik
Modified: 2008-11-11 14:01 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Lukas Hasik 2008-10-03 15:14:33 UTC
Build: NetBeans IDE Dev (Build 081002)
VM: Java HotSpot(TM) Client VM, 1.5.0_14-b03, Java(TM) 2 Runtime Environment, Standard Edition, 1.5.0_14-b03
OS: Windows XP, 5.1, x86

User comments: just opened nb module and wanted to expand libraries node in projects view

STACKTRACE: (first 10 lines)
java.lang.IllegalStateException: Should not acquire Children.MUTEX while holding ProjectManager.mutex()
        at org.openide.nodes.Children$ProjectManagerDeadlockDetector.execute(Children.java:1809)
        at org.openide.util.Mutex.postRequest(Mutex.java:1245)
        at org.openide.util.Mutex.postRequest(Mutex.java:1209)
        at org.openide.util.Mutex.postWriteRequest(Mutex.java:582)
        at org.openide.nodes.Children$Keys.applyKeys(Children.java:1515)
        at org.openide.nodes.Children$Keys.setKeys(Children.java:1459)
        at
org.netbeans.modules.apisupport.project.ui.UnitTestLibrariesNode$LibrariesChildren.access$200(UnitTestLibrariesNode.java:156)
        at
org.netbeans.modules.apisupport.project.ui.UnitTestLibrariesNode$LibrariesChildren$1$1.run(UnitTestLibrariesNode.java:205)
        at
org.netbeans.modules.apisupport.project.ui.UnitTestLibrariesNode$LibrariesChildren$1.run(UnitTestLibrariesNode.java:211)
        at org.openide.util.Mutex.readAccess(Mutex.java:327)
Comment 1 Jesse Glick 2008-10-03 16:45:15 UTC
Possible deadlock cause.
Comment 2 rmichalsky 2008-10-06 14:01:47 UTC
Info from Tomas: calls to nodes should be made outside of ProjectManager.mutex (via invokeLater or RP)
Comment 3 Tomas Danek 2008-10-07 13:19:20 UTC
*** Issue 149357 has been marked as a duplicate of this issue. ***
Comment 4 rmichalsky 2008-10-08 12:49:13 UTC
Had to be fixed together with issue #149084, done in core-main #eaebd48599b8
Comment 5 Quality Engineering 2008-10-09 06:00:56 UTC
Integrated into 'main-golden', will be available in build *200810090201* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/eaebd48599b8
User: Richard Michalsky <rmichalsky@netbeans.org>
Log: #149084, #149080: calls to nodes must be made outside of ProjectManager.mutex
Comment 6 Exceptions Reporter 2008-10-19 20:22:32 UTC
Reopening - reproduced in NetBeans IDE Dev (Build 200810171401)
http://statistics.netbeans.org/exceptions/detail.do?id=130518
Comment 7 Lukas Hasik 2008-10-19 22:29:32 UTC
closing as fixed again ex.report 130518 reported as 150666
Comment 8 Exceptions Reporter 2008-11-11 08:36:17 UTC
Reopening - reproduced in NetBeans IDE Dev (Build 200811071401)
http://statistics.netbeans.org/exceptions/detail.do?id=138256
Comment 9 Exceptions Reporter 2008-11-11 09:35:17 UTC
Reopening - reproduced in NetBeans IDE Dev (Build 200811071401)
http://statistics.netbeans.org/exceptions/detail.do?id=138272
Comment 10 rmichalsky 2008-11-11 14:01:32 UTC
Exceptions reporter found wrong stacktrace (again :-(), filing separate issue #152956 for e.r. 138256, 138272.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo