Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 148763 - c++ project toolchain
c++ project toolchain
Status: VERIFIED FIXED
Product: cnd
Classification: Unclassified
Component: -- Other --
6.x
PC Linux
: P2 (vote)
: 6.x
Assigned To: Alexey Vladykin
issues@cnd
65fixes1-verified
:
: 153503 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-30 16:14 UTC by afpribeiro
Modified: 2009-02-19 20:29 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
<project-dir>/nbproject/configurations.xml (286.33 KB, text/xml)
2008-09-30 16:17 UTC, afpribeiro
Details
<user-dir>/config/Preferences/org/netbeans/modules.cnd.properties. (2.52 KB, text/plain)
2008-09-30 16:19 UTC, afpribeiro
Details

Note You need to log in before you can comment on or make changes to this bug.
Description afpribeiro 2008-09-30 16:14:23 UTC
Hi,
 Im working project in c++ but we use ARM toolchain to compile it. At 
 NB C++ definitions we can add this toolchain and compile it but when 
 we restart NB those definitions are lost.

 Does anyone know how to keep that information?
Comment 1 afpribeiro 2008-09-30 16:17:54 UTC
Created attachment 70916 [details]
<project-dir>/nbproject/configurations.xml
Comment 2 afpribeiro 2008-09-30 16:19:10 UTC
Created attachment 70917 [details]
<user-dir>/config/Preferences/org/netbeans/modules.cnd.properties.
Comment 3 Alexey Vladykin 2008-10-02 15:42:58 UTC
When creating your custom toolchain please specify Tool Collection Family as "GNU", not "Unknown".
Currently CompilerSetManager just skips unknown toolchains found in cnd.properties.
Comment 4 alibabashack 2008-11-19 08:11:12 UTC
It is not possible to select GNU any more (6.5rc2)? I could not create a GNU based toolchain (arm-elf-gcc)
Comment 5 Alexey Vladykin 2008-11-20 11:20:48 UTC
GNU tool collection family should be selectable in NB6.5. Could you please upgrade to the 6.5 final and try with a fresh
userdir?
Comment 6 Alexey Vladykin 2008-11-20 15:09:11 UTC
*** Issue 153503 has been marked as a duplicate of this issue. ***
Comment 7 Leonid Lenyashin 2008-11-20 17:14:49 UTC
This sounds very serious. We should fix it asap and consider including to some of upcoming patches. Alexey or Thomas,
please, take a look.
Comment 8 Alexey Vladykin 2008-11-21 11:40:58 UTC
What is your OS?
I've just checked NB 6.5. Results:
- GNU family is selectable on Linux
- GNU family is NOT selectable on Windows (this could be the problem)
Comment 9 Alexey Vladykin 2008-11-21 14:25:59 UTC
Fixed in http://hg.netbeans.org/main/rev/a7bdba1012ee.
Toolchains with "Unknown" family are correctly restored after IDE restart now.
If "GNU" family does not appear when creating new toochain on Linux, please file a new IZ.
Comment 10 Alexander Pepin 2008-11-21 21:48:15 UTC
verified in dev build 4379
I was able create a new Unknown tool collection and it worked after restart IDE
Comment 11 Quality Engineering 2008-11-23 17:08:15 UTC
Integrated into 'main-golden', will be available in build *200811231401* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/a7bdba1012ee
User: Alexey Vladykin <alexey_vladykin@netbeans.org>
Log: #148763: c++ project toolchain
Comment 12 pslechta 2008-11-25 12:11:11 UTC
The fix was ported into release65_fixes repository.

http://hg.netbeans.org/release65_fixes/rev/148545d4b230
Comment 13 Alexander Pepin 2008-12-01 17:03:16 UTC
verified in 6.5 with patch1


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo