Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 148682 - [65cat] Adding multiple INDEX of same name
[65cat] Adding multiple INDEX of same name
Status: VERIFIED FIXED
Product: db
Classification: Unclassified
Component: Code
6.x
PC Windows Vista
: P3 (vote)
: 6.x
Assigned To: David Vancouvering
issues@db
65fixes1-verified
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-29 21:26 UTC by sunbiz
Modified: 2008-12-11 22:29 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description sunbiz 2008-09-29 21:26:54 UTC
[ BUILD # : 200809271401 ]
[ JDK VERSION : other ]

When creating index on database tables for javadb, we can add index 
with the same name multiple number of times. Netbeans should not 
allow multiple indexes to have the same name. When deleting one of 
the indexes, all the indexes with the same names are also deleted
Comment 1 David Vancouvering 2008-10-30 05:25:55 UTC
d49129f16c9a
Comment 2 Roman Mostyka 2008-10-30 18:16:42 UTC
Verified with build 081030.
Comment 3 Quality Engineering 2008-10-31 04:46:41 UTC
Integrated into 'main-golden', will be available in build *200810310201* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/d49129f16c9a
User: David Van Couvering <davidvc@netbeans.org>
Log: #148682: [65cat] Adding multiple INDEX of same name
Comment 4 pgebauer 2008-11-10 15:05:39 UTC
Since this issue is P3 priority, in accord with rules "How to include issues into patch"
(http://wiki.netbeans.org/NetBeansPatches) it must include an explanation as to why its backport is necessary and how
safe it is.

Could you please provide such explanation?
Comment 5 Roman Mostyka 2008-11-10 17:51:39 UTC
This issue is better to have in Patch 1 because when deleting one of the indexes, all the indexes with the same names
are also deleted. So the problem is more about consequences (and they can be quite bad) than about issue itself.
But if anybody think that it is rare case, then I can remove status whiteboard.
David, could you tell how the fix is safe?
Comment 6 rbalada 2008-11-14 11:11:25 UTC
I've transplanted the changeset http://hg.netbeans.org/main/rev/d49129f16c9a into release65_fixes repository as
http://hg.netbeans.org/release65_fixes/rev/0f726c5ceeec


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo