Sometimes I decide to flip the logic of a boolean variable. For example, I may want to rename "isDisabled" to "isEnabled". I think it would be a neat feature to
automatically search the code for usages of that boolean, then carefully flip the logic... adding or removing a '!' where necessary. Maybe this could be
integrated into the "rename" feature as an option when it detects you're renaming a boolean?
In general I think it's always best to name booleans in the "positive" sense, but even I sometimes forget and need to fix it later.
try to use jackpot
Initial revision pushed to trunk