Bug 148534 - [65cat] [ide] Following plugin install and update, System Proxy settings are not used properly
[65cat] [ide] Following plugin install and update, System Proxy settings are ...
Status: RESOLVED DUPLICATE of bug 201731
Product: platform
Classification: Unclassified
Component: Options&Settings
6.x
All All
: P3 (vote)
: 7.4
Assigned To: Jiri Rechtacek
issues@platform
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-26 23:18 UTC by esmithbss
Modified: 2013-04-04 10:34 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
Log from initial startup of 200809251401 (49.09 KB, text/plain)
2008-09-26 23:19 UTC, esmithbss
Details
Log from restart after loading plugins startup of 200809251401 (52.18 KB, text/plain)
2008-09-26 23:20 UTC, esmithbss
Details

Note You need to log in before you can comment on or make changes to this bug.
Description esmithbss 2008-09-26 23:18:54 UTC
[ BUILD # : 200809251401 ]
[ JDK VERSION : 1.6.0_07 ]

I just installed the 200809251401 build (with fix for #141924) to
check use of Environment Settings for proxy.  While the environment
settings work when the IDE is started, if you install a plugin that
requires a restart of the IDE, once the IDE is restarted, the
environment settings are ignored until you close and restart the IDE.
Comment 1 esmithbss 2008-09-26 23:19:48 UTC
Created attachment 70709 [details]
Log from initial startup of 200809251401
Comment 2 esmithbss 2008-09-26 23:20:28 UTC
Created attachment 70710 [details]
Log from restart after loading plugins startup of 200809251401
Comment 3 esmithbss 2008-09-26 23:21:29 UTC
This could be related to issue #141725 dealing with proxy values being refreshed after launching the IDE.
Comment 4 Jiri Rechtacek 2008-09-30 18:10:00 UTC
I confirm this behavior. System Setting are read from system only once while launching NetBeans by native launcher. Then
there is no way how to do listening on changes in system's environment. A good suggestion might be re-read system
setting while restarting IDE due install some plugins. I will be track this one as enhancement for next release. It is
not a right time now to change native launchers where any change would be too risky.
Comment 5 Jaroslav Tulach 2010-04-12 19:36:55 UTC
So Jiří, isn't it the right time to re-read the settings?
Comment 6 Libor Fischmeistr 2013-04-04 10:34:19 UTC

*** This bug has been marked as a duplicate of bug 201731 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo