Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 148522 - Need to add newly created module org.netbeans.modules.xml.wsdlui.api as friend of xml.xam, xml.xam.ui and catalogsupport
Need to add newly created module org.netbeans.modules.xml.wsdlui.api as frien...
Status: VERIFIED FIXED
Product: xml
Classification: Unclassified
Component: XAM
5.x
All All
: P3 (vote)
: 6.x
Assigned To: Samaresh Panda
issues@xml
61fixes4-fixed
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-26 21:35 UTC by malkit
Modified: 2008-10-15 21:52 UTC (History)
1 user (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description malkit 2008-09-26 21:35:06 UTC
As part of development of WLM (worklist Manger) Module (to be checked into soa-dev repository, part of tooling support
for Project Open-ESB), I created a new module org.netbeans.modules.xml.wsdlui.api. This module need to work with WSDL
Model and hence need be added friend to the following modules.

- xml.xam
- xml.xam.ui
- catalogsupport

Please do the needful.
Comment 1 Ritesh Adval 2008-09-26 21:49:58 UTC
adding 61fixes4-candidate to status.
Comment 2 Samaresh Panda 2008-09-26 22:36:23 UTC
How can I explain, enhancements are enhancements. They are normally developed/fixed in new releases and not in patches.
Secondly, why would you need to create a new module for a patch? Seems like a whole new set of functionality are being
added as a patch.
Comment 3 Samaresh Panda 2008-10-01 21:53:45 UTC
malkit, are you trying to expose some of these internal APIs through your module? If so, let me add a word of caution
that friends are friends. There is no formal contract between them and the APIs can change anytime.

Please read this: http://openide.netbeans.org/tutorial/api-design.html#life and read the friend relationship.
Comment 4 malkit 2008-10-01 22:57:23 UTC
As regards to my talk with Samaresh just now, here is the complete list of modules that I would need to be added as
friend to this new module.

xml.xam.ui
xml.validation
xml.refactoring
xml.catalogsupport
xml.axi
xml.wsdl.refactoring
Comment 5 Samaresh Panda 2008-10-02 01:47:13 UTC
Added: http://hg.netbeans.org/main?cmd=changeset;node=864c2e0a27b2.
Comment 6 pgebauer 2008-10-02 17:10:37 UTC
Could QE verified the issue in the trunk ASAP? Sustaining needs to port the changeset into the release61_fixes by Friday
03-Oct-08 and the issue have to be verified in trunk before the port. Thanks!!
Comment 7 malkit 2008-10-02 19:50:24 UTC
While we are waiting for QE to verify this, if my verification helps, I can verify (looking at the changeset) that for
6.5 all the requested modules have allowed friend access to this module. 
Comment 8 jlautz 2008-10-03 04:18:38 UTC
Verified on Windows Vista with Netbeans 6.5 trunk hudson continuous build #3954 from
http://deadlock.netbeans.org/hudson/job/trunk/.

(As of 10:13 pm Central US time, the nightly builds at http://bits.netbeans.org/dev/nightly/ hadn't appeared.)

The following modules now include org.netbeans.modules.xml.wsdlui.api in the OpenIDE-Module-Friends in their
META-INFO/MANIFEST.MF files (all directories relative to <netbeans_main>:

xml.xam.ui (xml2/modules/org-netbeans-modules-xml-xam-ui.jar)
xml.validation (xml2/modules/org-netbeans-modules-xml-validation.jar)
xml.refactoring (xml2/modules/org-netbeans-modules-xml-refactoring.jar)
xml.catalogsupport (xml2/modules/org-netbeans-modules-xml-catalogsupport.jar)
xml.axi (ide10/modules/org-netbeans-modules-xml-axi.jar)
xml.wsdl.refactoring (xml2/modules/org-netbeans-modules-xml-wsdl-refactoring.jar)
Comment 9 pgebauer 2008-10-03 10:21:43 UTC
I will proceed with porting to release61_fixes branch based on the above comment. Once the issue is verified in a
nightly build at bits.netbeans.org change, please the issue status to verified.
Comment 10 pgebauer 2008-10-03 10:28:17 UTC
The fix has been ported into the release61_fixes branch:

http://hg.netbeans.org/release61_fixes/rev/457a7e3b3b42
Comment 11 Quality Engineering 2008-10-03 14:29:35 UTC
Integrated into 'main-golden', will be available in build *200810031107* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/864c2e0a27b2
User: samaresh@netbeans.org
Log: #148522 Added org.netbeans.modules.xml.wsdlui.api as friend to 6 xml modules.
Comment 12 jlautz 2008-10-07 00:06:46 UTC
Verified on NB 6.1 with patch 4 installed:

The following modules now include org.netbeans.modules.xml.wsdlui.api in the OpenIDE-Module-Friends in their
META-INFO/MANIFEST.MF files (all directories relative to <netbeans_main>:

xml.xam.ui (xml2/modules/org-netbeans-modules-xml-xam-ui.jar)
xml.validation (xml2/modules/org-netbeans-modules-xml-validation.jar)
xml.refactoring (xml2/modules/org-netbeans-modules-xml-refactoring.jar) 
xml.catalogsupport (xml2/modules/org-netbeans-modules-xml-catalogsupport.jar)
xml.axi (ide9/modules/org-netbeans-modules-xml-axi.jar) <== NOTE Different ide # than for NB 6.5.
xml.wsdl.refactoring (xml2/modules/org-netbeans-modules-xml-wsdl-refactoring.jar)
Comment 13 jlautz 2008-10-07 00:43:22 UTC
Verified with NB 6.5 netbeans-trunk-nightly-200810031107-windows.exe as described in earlier comments for NB 6.5 builds.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo