Bug 14834 - Windows - could not be opened - problems with deserialization
Windows - could not be opened - problems with deserialization
Status: CLOSED INVALID
Product: projects
Classification: Unclassified
Component: Generic Infrastructure
3.x
PC Windows ME/2000
: P1 (vote)
: 3.x
Assigned To: Damian Frach
issues@projects
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2001-08-27 19:08 UTC by emmanuel
Modified: 2003-07-01 14:16 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
NB - log (109.73 KB, text/plain)
2001-08-27 19:10 UTC, emmanuel
Details

Note You need to log in before you can comment on or make changes to this bug.
Description emmanuel 2001-08-27 19:08:10 UTC
Q-build candidate 200108240715 gives above Exception.

As a result I cannot work with this NB version.

When importing an existing project I get this exception, steps;
Import existing project.

When creating new project I get this exception, steps;
Mount CVS directory.
Mount local directory.
Set target for external compiler.
get exception.

Could this be attended to - and if possible for this candidate.

Kind regards
Emmanuel
Comment 1 emmanuel 2001-08-27 19:10:11 UTC
Created attachment 2313 [details]
NB - log
Comment 2 Vitezslav Stejskal 2001-08-28 10:12:18 UTC
Window deserialization problem during the import of project seems to 
be caused by Web module, at least exceptions in ide.log are thrown due 
to the problem with deserialization of .../WEB_INF/classes node.

I am not sure about the second problem, mounting filesystems, 
exceptions are thrown from vcscore module.

Damian, Martin could you look at it, please. BTW Emmanuel, can you 
attach the user directory where are you importing projects from, it 
can help us to reproduce your problems.
Comment 3 Martin Entlicher 2001-08-28 13:03:20 UTC
The exception from VcsFileSystem should not hurt anything. It's a
localized exception thrown when someone wants an input stream of a
file, that is not physically present on the disk.
Comment 4 emmanuel 2001-08-29 07:32:32 UTC
With 200108240715-qbe2, this works fine until I do something which 
affects this.  I'm in the process of finding what exactly 
creates these side effects.  Will post my findings once I have the 
exact pattern.

BTW, I suspect 0824 probably also works fine - I probably hit the 
condition sooner which caused these side effects immediately.
 
Kind regards
Emmanuel
Comment 5 emmanuel 2001-08-29 21:33:42 UTC
I've spent hours to pinpoint the exact cause.  I cannot clearly get 
at it.

What I did notice though;
Item 1.  I had a file [projectid.xml] which used to be part of the 
CVS working directory (in 0703), but was deleted (in 0703), this 
missing file caused an exception in 0824-qbe2 - see attached 
ide.log.  And once I added this file locally to the CVS working 
directory, 0824 was stable.

Item 2. the 'explore from here' windows which I'm fond of using and 
docking in the debugger window, never opens after restarting NB.  
Those windows warnings are also in ide.log.

It seems NB becomes very iratic after item 1 occurs.

Could you please attend to items 1 & 2.

Kind regards
Emmanuel
Comment 6 emmanuel 2001-09-01 13:49:11 UTC
I cannot pinpoint this and will relook.
Comment 7 Jaromir Uhrik 2001-10-10 14:17:20 UTC
Marking as VERIFIED because unable to see such behaviour in dev33 
build #200110100100.
Comment 8 Quality Engineering 2003-07-01 14:16:56 UTC
Resolved for 3.4.x or earlier, no new info since then -> closing.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo