Bug 148324 - [65cat] OutOfMemoryError: Java heap space
[65cat] OutOfMemoryError: Java heap space
Status: RESOLVED FIXED
Product: platform
Classification: Unclassified
Component: Autoupdate
6.x
All All
: P3 (vote)
: 6.x
Assigned To: dlipin
issues@platform
http://statistics.netbeans.org/except...
EXCEPTIONS_REPORT
: ARCH
: 126219 166725 (view as bug list)
Depends on: 149071
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-25 10:11 UTC by ulfzibis
Modified: 2009-09-02 16:47 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
log file (183.19 KB, text/plain)
2008-09-25 10:13 UTC, ulfzibis
Details
uigestures (585 bytes, text/plain)
2008-09-25 10:13 UTC, ulfzibis
Details
patch for handling licenses using the file system cache (4.32 KB, patch)
2009-03-02 12:47 UTC, dlipin
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description ulfzibis 2008-09-25 10:11:30 UTC
Build: NetBeans IDE Dev (Build 200809220201)
VM: Java HotSpot(TM) Client VM, 11.0-b15, Java(TM) SE Runtime Environment, 1.6.0_10-rc-b28
OS: Windows XP, 5.1, x86
User comments: Just started PC from hibernation, NetBeans IDE was open.
STACKTRACE: (first 10 lines)
java.lang.OutOfMemoryError: Java heap space
        at com.sun.org.apache.xerces.internal.util.XMLStringBuffer.append(XMLStringBuffer.java:205)
        at com.sun.org.apache.xerces.internal.impl.XMLDocumentScannerImpl.refresh(XMLDocumentScannerImpl.java:1520)
        at com.sun.org.apache.xerces.internal.impl.XMLEntityScanner.invokeListeners(XMLEntityScanner.java:2070)
        at com.sun.org.apache.xerces.internal.impl.XMLEntityScanner.peekChar(XMLEntityScanner.java:486)
        at
com.sun.org.apache.xerces.internal.impl.XMLDocumentFragmentScannerImpl$FragmentContentDriver.next(XMLDocumentFragmentScannerImpl.java:2679)
        at com.sun.org.apache.xerces.internal.impl.XMLDocumentScannerImpl.next(XMLDocumentScannerImpl.java:648)
        at
com.sun.org.apache.xerces.internal.impl.XMLDocumentFragmentScannerImpl.scanDocument(XMLDocumentFragmentScannerImpl.java:510)
        at com.sun.org.apache.xerces.internal.parsers.XML11Configuration.parse(XML11Configuration.java:807)
        at com.sun.org.apache.xerces.internal.parsers.XML11Configuration.parse(XML11Configuration.java:737)
        at com.sun.org.apache.xerces.internal.parsers.XMLParser.parse(XMLParser.java:107)
Comment 1 ulfzibis 2008-09-25 10:13:05 UTC
Created attachment 70553 [details]
log file
Comment 2 ulfzibis 2008-09-25 10:13:48 UTC
Created attachment 70554 [details]
uigestures
Comment 3 Jiri Rechtacek 2008-09-29 13:05:33 UTC
Most of memory consumption was fixed in issue 124482, the expensive DOM parser was replaced by liter SAX parser. But
still parsing of content Update Centers need a plenty of memory, the biggest part of memory is taken by plugin's
licenses. For a next releases would be best to separate off licenses from Update Center Descriptor and handle them
separately from UCs.
Comment 4 Jiri Rechtacek 2008-10-10 13:23:14 UTC
*** Issue 126219 has been marked as a duplicate of this issue. ***
Comment 5 Antonin Nebuzelsky 2008-11-14 15:32:50 UTC
Reassigning to the new "autoupdate/*" owner dlipin.
Comment 6 dlipin 2009-03-02 12:46:44 UTC
To significantly decrease the possibility of OOMs while dealing with plugins` licenses we can also dump licenses to 
disk while parsing catalog, and then retrieving (reading from disk) them on demand. This will help to avoid storing all 
licenses contents in memory. Certainly, such handling will be a little bit slower that existing one.

The proposed patch (can be with bugs) is attached.
Comment 7 dlipin 2009-03-02 12:47:54 UTC
Created attachment 77559 [details]
patch for handling licenses using the file system cache
Comment 8 dlipin 2009-03-06 10:04:18 UTC
should be fixed together with 149071.
http://hg.netbeans.org/core-main/rev/2de5072bf5e7
Comment 9 dlipin 2009-06-08 15:39:52 UTC
*** Issue 166725 has been marked as a duplicate of this issue. ***
Comment 10 Anton Chechel 2009-06-08 15:48:55 UTC
It is not fixed. Still occurred in 200903060201 build. See http://www.netbeans.org/issues/show_bug.cgi?id=166725
Comment 11 dlipin 2009-06-08 15:52:55 UTC
Build 200903060201 belongs to the 6.5(.1) codeline which is handled separately from 6.7. 

This issue is fixed in recent daily builds and also in 6.7 M3, 6.7 Beta, 6.7 RCx and all futher 6.7 and post-6.7 builds.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo