Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 148220 - org.netbeans.modules.j2ee classes are loaded on NetBeans startup with LimeWire project
org.netbeans.modules.j2ee classes are loaded on NetBeans startup with LimeWir...
Status: VERIFIED DUPLICATE of bug 148177
Product: serverplugins
Classification: Unclassified
Component: Infrastructure
6.x
PC Windows XP
: P2 (vote)
: TBD
Assigned To: Petr Hejl
issues@serverplugins
http://wiki.netbeans.org/FitnessViaWh...
: PERFORMANCE, TEST
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-24 13:43 UTC by Alexander Kouznetsov
Modified: 2008-10-02 14:42 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
Stacktraces (110.94 KB, text/plain)
2008-09-24 13:46 UTC, Alexander Kouznetsov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alexander Kouznetsov 2008-09-24 13:43:38 UTC
Performance test reports that the following classes are loaded on NetBeans startup with LimeWare project:

    org.netbeans.modules.j2ee.sun.ide.dm.Bundle
    org.netbeans.modules.j2ee.sun.ide.dm.Bundle_ru
    org.netbeans.modules.j2ee.sun.ide.dm.Bundle_ru_RU
    org.netbeans.modules.j2ee.sun.ide.dm.Constants
    org.netbeans.modules.j2ee.sun.ide.dm.SunDeploymentFactory
    org.netbeans.modules.j2ee.sun.ide.j2ee.Constants
    org.netbeans.modules.j2ee.sun.ide.j2ee.OptionalFactory
    org.netbeans.modules.j2ee.sun.ide.j2ee.PluginProperties
    org.netbeans.modules.j2ee.sun.share.CharsetMapping
    org.netbeans.modules.j2ee.sun.share.SecurityMasterListModel
    org.netbeans.modules.j2ee.weblogic9.WLDeploymentFactory
    org.netbeans.modules.j2ee.weblogic9.WLDeploymentManager
    org.netbeans.modules.j2ee.weblogic9.optional.WLOptionalDeploymentManagerFactory
    org.netbeans.modules.j2ee.websphere6.WSDeploymentFactory
    org.netbeans.modules.j2ee.websphere6.WSVersion
    org.netbeans.modules.j2ee.websphere6.optional.WSOptionalDeploymentManagerFactory

Please don't load these classes unless they are really necessary.
Comment 1 Alexander Kouznetsov 2008-09-24 13:46:28 UTC
Created attachment 70458 [details]
Stacktraces
Comment 2 Petr Hejl 2008-09-24 14:20:10 UTC
Any justification for these being filed as P2?
Comment 3 Jaroslav Tulach 2008-09-30 10:53:00 UTC
Justification is similar to issue 148177. If you can do something to reduce the # of loaded classes, we'll be 
thankful.
Comment 4 Alexander Kouznetsov 2008-09-30 11:00:56 UTC
Updated the priority according to justification.
Comment 5 Petr Hejl 2008-10-02 12:11:14 UTC
The cause seems to be the same as for issue 148177.

*** This issue has been marked as a duplicate of 148177 ***
Comment 6 Alexander Kouznetsov 2008-10-02 14:42:39 UTC
ok


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo