Bug 148178 - org.netbeans.modules.j2ee.persistence* classes are loaded on NetBeans startup with LimeWire project
org.netbeans.modules.j2ee.persistence* classes are loaded on NetBeans startup...
Status: RESOLVED INVALID
Product: javaee
Classification: Unclassified
Component: Persistence
6.x
PC Windows XP
: P3 (vote)
: 8.0
Assigned To: Sergey Petrov
issues@javaee
http://wiki.netbeans.org/FitnessViaWh...
fix-in-67
: PERFORMANCE, TEST
: 177851 (view as bug list)
Depends on: 150194
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-24 10:15 UTC by Alexander Kouznetsov
Modified: 2014-01-28 11:23 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
Stacktraces (126.57 KB, text/plain)
2008-09-24 10:19 UTC, Alexander Kouznetsov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alexander Kouznetsov 2008-09-24 10:17:05 UTC
Performance test reports that the following classes are loaded on NetBeans startup with LimeWare project:

    org.netbeans.modules.j2ee.ejbverification.EJBVerificationTaskProvider
    org.netbeans.modules.j2ee.genericserver.GSDeploymentFactory
    org.netbeans.modules.j2ee.genericserver.ide.GSOptionalDeploymentManagerFactory
    org.netbeans.modules.j2ee.jboss4.JBDeploymentFactory
    org.netbeans.modules.j2ee.jboss4.ide.JBOptionalDeploymentManagerFactory
    org.netbeans.modules.j2ee.jboss4.ide.ui.JBPluginUtils
    org.netbeans.modules.j2ee.jboss4.ide.ui.JBPluginUtils$Version
    org.netbeans.modules.j2ee.jpa.verification.JPAVerificationTaskProvider
    org.netbeans.modules.j2ee.jpa.verification.api.VerificationWarningOverrider
    org.netbeans.modules.j2ee.persistence.api.EntityClassScope
    org.netbeans.modules.j2ee.persistence.api.PersistenceScope
    org.netbeans.modules.j2ee.persistence.api.PersistenceScopes
    org.netbeans.modules.j2ee.persistence.spi.EntityClassScopeFactory
    org.netbeans.modules.j2ee.persistence.spi.EntityClassScopeImplementation
    org.netbeans.modules.j2ee.persistence.spi.EntityClassScopeProvider
    org.netbeans.modules.j2ee.persistence.spi.PersistenceLocationProvider
    org.netbeans.modules.j2ee.persistence.spi.PersistenceScopeFactory
    org.netbeans.modules.j2ee.persistence.spi.PersistenceScopeImplementation
    org.netbeans.modules.j2ee.persistence.spi.PersistenceScopeProvider
    org.netbeans.modules.j2ee.persistence.spi.PersistenceScopesFactory
    org.netbeans.modules.j2ee.persistence.spi.PersistenceScopesImplementation
    org.netbeans.modules.j2ee.persistence.spi.PersistenceScopesProvider
    org.netbeans.modules.j2ee.persistence.spi.support.EntityMappingsMetadataModelHelper
    org.netbeans.modules.j2ee.persistence.spi.support.PersistenceScopesHelper
    org.netbeans.modules.j2ee.persistence.spi.support.PersistenceScopesHelper$FileListener
    org.netbeans.modules.j2ee.persistence.spi.support.PersistenceScopesHelper$PersistenceScopesImpl
    org.netbeans.modules.j2ee.persistenceapi.EntityClassScopeAccessor
    org.netbeans.modules.j2ee.persistenceapi.FileChangeSupport
    org.netbeans.modules.j2ee.persistenceapi.FileChangeSupport$Holder
    org.netbeans.modules.j2ee.persistenceapi.FileChangeSupportListener
    org.netbeans.modules.j2ee.persistenceapi.PersistenceScopeAccessor
    org.netbeans.modules.j2ee.persistenceapi.PersistenceScopesAccessor

Please don't load these classes unless they are really necessary.
Comment 1 Alexander Kouznetsov 2008-09-24 10:19:11 UTC
Created attachment 70420 [details]
Stacktraces
Comment 2 _ jyothivasa 2008-11-20 00:57:59 UTC
Plan to address this issue in the next release
Comment 3 Petr Jiricka 2009-05-12 15:14:22 UTC
I believe the situation could now be better because:
- due to ergonomics, the jboss and genericserver and ejbverification classes are hopefully not loaded
- the JPA verification was disabled in 6.7 (see issue 162133), which could help the jpa/persistence classes

Could you please test again and attach the latest list of undesirable classes? Thanks.
Comment 4 Petr Jiricka 2009-06-08 15:09:45 UTC
Waiting for more input.
Comment 5 Oleg Khokhlov 2009-06-10 17:17:43 UTC
build 20090608

    org.netbeans.modules.j2ee.genericserver.GSDeploymentFactory
    org.netbeans.modules.j2ee.genericserver.ide.GSOptionalDeploymentManagerFactory
    org.netbeans.modules.j2ee.jboss4.JBDeploymentFactory
    org.netbeans.modules.j2ee.jboss4.ide.JBOptionalDeploymentManagerFactory
    org.netbeans.modules.j2ee.jboss4.ide.ui.JBPluginUtils
    org.netbeans.modules.j2ee.jboss4.ide.ui.JBPluginUtils$Version
    org.netbeans.modules.j2ee.persistence.api.EntityClassScope
    org.netbeans.modules.j2ee.persistence.api.PersistenceScope
    org.netbeans.modules.j2ee.persistence.api.PersistenceScopes
    org.netbeans.modules.j2ee.persistence.spi.EntityClassScopeFactory
    org.netbeans.modules.j2ee.persistence.spi.EntityClassScopeImplementation
    org.netbeans.modules.j2ee.persistence.spi.EntityClassScopeProvider
    org.netbeans.modules.j2ee.persistence.spi.PersistenceLocationProvider
    org.netbeans.modules.j2ee.persistence.spi.PersistenceScopeFactory
    org.netbeans.modules.j2ee.persistence.spi.PersistenceScopeImplementation
    org.netbeans.modules.j2ee.persistence.spi.PersistenceScopeProvider
    org.netbeans.modules.j2ee.persistence.spi.PersistenceScopesFactory
    org.netbeans.modules.j2ee.persistence.spi.PersistenceScopesImplementation
    org.netbeans.modules.j2ee.persistence.spi.PersistenceScopesProvider
    org.netbeans.modules.j2ee.persistence.spi.support.EntityMappingsMetadataModelHelper
    org.netbeans.modules.j2ee.persistence.spi.support.PersistenceScopesHelper
    org.netbeans.modules.j2ee.persistence.spi.support.PersistenceScopesHelper$FileListener
    org.netbeans.modules.j2ee.persistence.spi.support.PersistenceScopesHelper$PersistenceScopesImpl
    org.netbeans.modules.j2ee.persistenceapi.EntityClassScopeAccessor
    org.netbeans.modules.j2ee.persistenceapi.FileChangeSupport
    org.netbeans.modules.j2ee.persistenceapi.FileChangeSupport$Holder
    org.netbeans.modules.j2ee.persistenceapi.FileChangeSupportListener
    org.netbeans.modules.j2ee.persistenceapi.PersistenceScopeAccessor
    org.netbeans.modules.j2ee.persistenceapi.PersistenceScopesAccessor
    org.netbeans.modules.j2ee.sun.api.ServerLocationManager
    org.netbeans.modules.j2ee.sun.ide.dm.Bundle
    org.netbeans.modules.j2ee.sun.ide.dm.Bundle_en
    org.netbeans.modules.j2ee.sun.ide.dm.Bundle_en_US
    org.netbeans.modules.j2ee.sun.ide.dm.Constants
    org.netbeans.modules.j2ee.sun.ide.dm.SunDeploymentFactory
    org.netbeans.modules.j2ee.sun.ide.j2ee.Constants
    org.netbeans.modules.j2ee.sun.ide.j2ee.OptionalFactory
    org.netbeans.modules.j2ee.sun.ide.j2ee.PluginProperties
    org.netbeans.modules.j2ee.sun.ide.j2ee.RunTimeDDCatalog
    org.netbeans.modules.j2ee.sun.share.CharsetMapping
    org.netbeans.modules.j2ee.sun.share.SecurityMasterListModel
    org.netbeans.modules.j2ee.weblogic9.WLDeploymentFactory
    org.netbeans.modules.j2ee.weblogic9.WLDeploymentManager
    org.netbeans.modules.j2ee.weblogic9.optional.WLOptionalDeploymentManagerFactory
Comment 6 Petr Jiricka 2009-06-11 09:19:44 UTC
Thanks! Let's use this issue to track classes from j2ee.persistence - the ones from the server plugins are already
tracked in issue 148177. So the list of relevant classes is:

    org.netbeans.modules.j2ee.persistence.api.EntityClassScope
    org.netbeans.modules.j2ee.persistence.api.PersistenceScope
    org.netbeans.modules.j2ee.persistence.api.PersistenceScopes
    org.netbeans.modules.j2ee.persistence.spi.EntityClassScopeFactory
    org.netbeans.modules.j2ee.persistence.spi.EntityClassScopeImplementation
    org.netbeans.modules.j2ee.persistence.spi.EntityClassScopeProvider
    org.netbeans.modules.j2ee.persistence.spi.PersistenceLocationProvider
    org.netbeans.modules.j2ee.persistence.spi.PersistenceScopeFactory
    org.netbeans.modules.j2ee.persistence.spi.PersistenceScopeImplementation
    org.netbeans.modules.j2ee.persistence.spi.PersistenceScopeProvider
    org.netbeans.modules.j2ee.persistence.spi.PersistenceScopesFactory
    org.netbeans.modules.j2ee.persistence.spi.PersistenceScopesImplementation
    org.netbeans.modules.j2ee.persistence.spi.PersistenceScopesProvider
    org.netbeans.modules.j2ee.persistence.spi.support.EntityMappingsMetadataModelHelper
    org.netbeans.modules.j2ee.persistence.spi.support.PersistenceScopesHelper
    org.netbeans.modules.j2ee.persistence.spi.support.PersistenceScopesHelper$FileListener
    org.netbeans.modules.j2ee.persistence.spi.support.PersistenceScopesHelper$PersistenceScopesImpl
    org.netbeans.modules.j2ee.persistenceapi.EntityClassScopeAccessor
    org.netbeans.modules.j2ee.persistenceapi.FileChangeSupport
    org.netbeans.modules.j2ee.persistenceapi.FileChangeSupport$Holder
    org.netbeans.modules.j2ee.persistenceapi.FileChangeSupportListener
    org.netbeans.modules.j2ee.persistenceapi.PersistenceScopeAccessor
    org.netbeans.modules.j2ee.persistenceapi.PersistenceScopesAccessor

Reassigning to the persistence subcategory.
Comment 7 Sergey Petrov 2009-09-22 11:47:37 UTC
do you mean I need to download limeware sources from limewire.org, create project(if it's not in sources) and start ide?
what is criteria for unneeded and irrelevant classes/needed and relevant classes?
Comment 8 Sergey Petrov 2009-09-22 12:33:11 UTC
test:
./ide.kit/test/whitelist
//

some(or all) classes may be required in j2se project as j2se support jpa, need to evaluate
Comment 9 Sergey Petrov 2009-10-01 12:48:49 UTC
there is also org.netbeans.modules.j2ee.jpa.verification.JPAProblemFinderFactory loaded, but in my opinion it ok to scan
if there are persistence problems.
Comment 10 Sergey Petrov 2009-10-01 12:49:44 UTC
looks like ost other classes are used by scanner, still need more investigation.
Comment 11 Sergey Petrov 2009-11-11 05:07:58 UTC
may use issue 173031 for actions part of classes as reference later (if will be resolved first).
Comment 12 Sergey Petrov 2010-02-11 04:00:58 UTC
*** Bug 177851 has been marked as a duplicate of this bug. ***
Comment 13 Sergey Petrov 2014-01-28 11:23:10 UTC
I'm still think it's required,
all listeners + *scope classes are looking for project modifications, i.e. if persistence.xml is added/removed etc, this functionality should be enabled even if no persistence.xml exists yet.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo