Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 148168 - [65cat] AssertionError: visnodes.size()=0 snapshot.size()=1
[65cat] AssertionError: visnodes.size()=0 snapshot.size()=1
Status: RESOLVED FIXED
Product: platform
Classification: Unclassified
Component: Explorer
6.x
All All
: P2 (vote)
: 6.x
Assigned To: t_h
issues@platform
http://statistics.netbeans.org/except...
65fixes2-verified EXCEPTIONS_REPORT
:
: 148319 148622 148851 149205 149953 151721 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-24 09:11 UTC by _ theanuradha
Modified: 2009-10-13 11:59 UTC (History)
26 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (1.21 KB, text/plain)
2008-09-24 09:11 UTC, _ theanuradha
Details
stacktrace (7.84 KB, text/plain)
2008-10-09 15:43 UTC, vanob
Details
messages.log (6.42 MB, text/plain)
2008-10-15 12:53 UTC, aldobrucale
Details

Note You need to log in before you can comment on or make changes to this bug.
Description _ theanuradha 2008-09-24 09:11:49 UTC
Build: NetBeans IDE Dev (Build 080924)
VM: Java HotSpot(TM) Client VM, 11.0-b14, Java(TM) SE Runtime Environment, 1.6.0_10-rc-b27
OS: Windows XP, 5.1, x86

Stacktrace: 
java.lang.AssertionError: visnodes.size()=0 snapshot.size()=1
        at org.openide.explorer.view.VisualizerChildren.recomputeIndexes(VisualizerChildren.java:87)
        at org.openide.explorer.view.VisualizerChildren.removed(VisualizerChildren.java:264)
        at org.openide.explorer.view.VisualizerEvent$Removed.run(VisualizerEvent.java:132)
        at org.openide.util.Mutex.readAccess(Mutex.java:362)
        at org.openide.explorer.view.VisualizerNode$QP.run(VisualizerNode.java:708)
        at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:209)
Comment 1 _ theanuradha 2008-09-24 09:11:59 UTC
Created attachment 70413 [details]
stacktrace
Comment 2 t_h 2008-09-27 08:12:27 UTC
*** Issue 148319 has been marked as a duplicate of this issue. ***
Comment 3 t_h 2008-09-28 22:10:46 UTC
0dceae044f0d  
Comment 4 Quality Engineering 2008-09-29 05:32:18 UTC
Integrated into 'main-golden', will be available in build *200809290201* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/0dceae044f0d
User: Tomas Holy <t_h@netbeans.org>
Log: Node.setChildren() was changed to generate correct snapshots and to avoid creation of all nodes in case of lazy children. Invalid snapshot could be reason for #139692, #148168, #147848, #147825
Comment 5 t_h 2008-10-01 14:50:38 UTC
*** Issue 148851 has been marked as a duplicate of this issue. ***
Comment 6 adam_myatt 2008-10-07 20:17:09 UTC
Though marked as fixed in buil 200809290201 (Sept 29) i just got this error in build 200810031942 (Oct 03).
Comment 7 t_h 2008-10-07 20:48:57 UTC
Some causes for this assertion were fixed lately (a8e67ec3eec0). If you still get this assertion please try to reproduce
with finer logging (-J-Dorg.openide.nodes.level=100). Thanks.
Comment 8 Exceptions Reporter 2008-10-08 15:11:25 UTC
Reopening - reproduced in NetBeans IDE Dev (Build 200810070201)
http://statistics.netbeans.org/exceptions/detail.do?id=124908
Comment 9 vanob 2008-10-09 15:43:00 UTC
Build: NetBeans IDE Dev (Build 200810090201)
VM: Java HotSpot(TM) Client VM, 11.0-b15, Java(TM) SE Runtime Environment, 1.6.0_10-rc2-b32
OS: Windows XP, 5.1, x86

User Comments: 


Stacktrace: 
java.lang.reflect.UndeclaredThrowableException
        at $Proxy.childrenRemoved(.java:0)
        at org.openide.nodes.Node.fireSubNodesChange(Node.java:1070)
        at org.openide.nodes.EntrySupport$Default.notifyRemove(EntrySupport.java:645)
        at org.openide.nodes.EntrySupport$Default.updateRemove(EntrySupport.java:368)
        at org.openide.nodes.EntrySupport$Default.setEntries(EntrySupport.java:323)
        at org.openide.nodes.Children$Keys$2.run(Children.java:1495)
Comment 10 vanob 2008-10-09 15:43:04 UTC
Created attachment 71471 [details]
stacktrace
Comment 11 t_h 2008-10-10 11:43:08 UTC
*** Issue 148622 has been marked as a duplicate of this issue. ***
Comment 12 t_h 2008-10-10 12:28:55 UTC
d0216ad21b66
Comment 13 Quality Engineering 2008-10-11 17:16:25 UTC
Integrated into 'main-golden', will be available in build *200810111401* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/d0216ad21b66
User: Tomas Holy <t_h@netbeans.org>
Log: Another event could be fired before current was delivered to all listeners. Fix for #148168 #147848
Comment 14 t_h 2008-10-13 15:45:38 UTC
*** Issue 149953 has been marked as a duplicate of this issue. ***
Comment 15 t_h 2008-10-15 10:32:25 UTC
*** Issue 149205 has been marked as a duplicate of this issue. ***
Comment 16 aldobrucale 2008-10-15 11:38:09 UTC
Maybe I should file another issue, but I got the same stacktrace in today's nightly build (200810150201). I was deleting
a folder from a (versioned) entry in the Favorites window. After the exception, the popup menu on subfolders in
favorites ony contains the "Add to Favorites..." item.
Comment 17 t_h 2008-10-15 12:16:47 UTC
Is it reproducible? Please provide steps how to reproduce or attach log with finer logging for nodes and explorer
(-J-Dorg.openide.nodes.level=100 -J-Dorg.openide.explorer.level=100)
Comment 18 aldobrucale 2008-10-15 12:53:36 UTC
Created attachment 71850 [details]
messages.log
Comment 19 t_h 2008-10-16 13:06:08 UTC
dbbb0824ccad
aldobrucale: thanks for log, please verify
Comment 20 aldobrucale 2008-10-16 18:31:57 UTC
When will the fix be included in the nightly build?
Comment 21 t_h 2008-10-16 20:49:11 UTC
It should be in next nightly build. Notification will be added here.
Comment 22 Quality Engineering 2008-10-17 04:59:28 UTC
Integrated into 'main-golden', will be available in build *200810170201* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/dbbb0824ccad
User: Tomas Holy <t_h@netbeans.org>
Log: #148168: (assert) #150293: Blank node in a Files view instead of a regular file.
Comment 23 aldobrucale 2008-10-17 09:11:36 UTC
It now works perfectly: thanks!
Comment 24 t_h 2008-10-29 14:17:31 UTC
*** Issue 151721 has been marked as a duplicate of this issue. ***
Comment 25 Exceptions Reporter 2008-11-14 07:12:40 UTC
Reopening - reproduced in NetBeans IDE Dev (Build 20081114010226)
http://statistics.netbeans.org/exceptions/detail.do?id=139412
Comment 26 Exceptions Reporter 2008-11-21 18:49:42 UTC
This issue has already 20 duplicates 
see http://statistics.netbeans.org/exceptions/detail.do?id=118889
Comment 27 t_h 2008-12-08 08:32:10 UTC
If someone meets this issue regularly, please try to reproduce with finer logging (-J-Dorg.openide.nodes.level=100
-J-Dorg.openide.explorer.level=100 as command line parameter) and attach log.
Comment 28 Exceptions Reporter 2008-12-26 13:38:45 UTC
This issue has already 50 duplicates 
see http://statistics.netbeans.org/exceptions/detail.do?id=117460
Comment 29 t_h 2009-01-05 15:44:48 UTC
a4ff22e34c71
Comment 30 Quality Engineering 2009-01-06 05:30:02 UTC
Integrated into 'main-golden', will be available in build *200901060201* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/a4ff22e34c71
User: Tomas Holy <t_h@netbeans.org>
Log: #148168: prevent firing another event while processing one
Comment 31 Tomas Danek 2009-01-12 13:19:15 UTC
did not occur recently -> marking as verified.
Comment 32 pgebauer 2009-01-12 16:41:25 UTC
The all changesets 0dceae044f0d, a8e67ec3eec0 and d0216ad21b66 are part of the release65_fixes branch. The changeset dbbb0824ccad was integrated 
into the release65 branch as d4b9791fc77a hence it is part of the release65_fixes branch as well. The remaining changeset to port is a4ff22e34c71.

The changeset a4ff22e34c71 has been ported into the release65_fixes repository.

http://hg.netbeans.org/release65_fixes/rev/9c9c6b2071e5
Comment 33 Tomas Danek 2009-01-16 15:30:42 UTC
verified in 6.5patch2. No regression was found, tried DnD in explorer, copy-pasting files from one project to another.
Comment 34 Exceptions Reporter 2009-02-01 09:22:21 UTC
Reopening - reproduced in NetBeans IDE Dev (Build 200901250201)
http://statistics.netbeans.org/exceptions/detail.do?id=118889
Comment 35 t_h 2009-02-03 11:46:36 UTC
New duplicate is caused by previously reported error:
"java.lang.IllegalStateException: Some of a set of deleted nodes are not present in the original ones.
See #15478; you may need to check that your Children.Keys keys are safely comparable."


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo