Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 147901 - incorrect focus after Alt+Tab on windows
incorrect focus after Alt+Tab on windows
Status: RESOLVED DUPLICATE of bug 73960
Product: platform
Classification: Unclassified
Component: Window System
6.x
PC Windows XP
: P3 (vote)
: TBD
Assigned To: David Simonek
issues@platform
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-22 16:50 UTC by mataal
Modified: 2008-12-22 13:36 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description mataal 2008-09-22 16:50:53 UTC
It seems there is some problem with the cacthing of the alt+tab event in windows. I am not sure if it occurs in older
versions too.

Repro steps. 
- Start netbeans
- Open a file (i was doing ruby files) and start editing
- Alt+Tab out to another file (i went to pdf reader to see the example code)
- Alt+Tab back to the IDE
- the focus is on the application menu (File), i would expect it to be on the last edited code window. [see url snapshot
of same- http://img176.imageshack.us/my.php?image=netbeans65alttabissuead0.png]
I automatically start typing and end up hitting a succession of menu short keys. :)

Is this because an extra "Alt" is being caught in the events or something?
Comment 1 Tomas Danek 2008-09-23 13:11:06 UTC
I can reproduce on Win XP. 

1) netbeans
2) alt+tab
3) other window 
4) alt+tab
5) netbeans -> everything is ok
6) alt+tab
7) other window 
8) alt+tab
5) netbeans -> "file" item in menu is selected!

I agree that this may be very annoying. Please reassign further.
Comment 2 Lukas Hasik 2008-09-23 13:16:42 UTC
unfortunately, known JDK bug :(
see the duplicate

*** This issue has been marked as a duplicate of 73960 ***
Comment 3 mataal 2008-09-23 14:49:26 UTC
:(
is there a problem with the bug database query page or am i missing something? i tried search strings "Alt Tab" and 
"Alt+Tab" to make sure i didn't report a duplicate, yet ended up doing so. :(


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo