Bug 14768 - New IDE Distro wizard
New IDE Distro wizard
Status: RESOLVED FIXED
Product: apisupport
Classification: Unclassified
Component: Project
3.x
All All
: P3 (vote)
: 5.x
Assigned To: Jesse Glick
issues@apisupport
:
: 14767 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2001-08-24 11:30 UTC by _ tboudreau
Modified: 2005-09-05 09:51 UTC (History)
0 users

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description _ tboudreau 2001-08-24 11:30:53 UTC
We encourage people to redistribute NetBeans as their own application.  It would
help to make this easier for people, in the following way - a wizard that allows
you to create a new distribution of the IDE, specify which modules should be in
it, branding, etc. and create the result as a zip file, based on the running
instance of the IDE.

Workflow would be something like:
 - Select splash screen, product name and other branding stuff
 - Select from the installed modules which modules should end up in the new distro
 - Saves current configuration of the IDE as default configuration of new distro
(e.g. editor colors, etc)
 - Choose from mounted filesystems to distribute example files with the new
distribution
 - Build the distribution
 - Offer to notify netbeans.org that this distribution exists, so it can be
added to the 3rd party page
Comment 1 Jan Zajicek 2001-09-05 08:14:31 UTC
*** Issue 14767 has been marked as a duplicate of this issue. ***
Comment 2 Jan Zajicek 2001-09-25 19:01:27 UTC
Just updating the component.
Comment 3 Jesse Glick 2002-02-20 11:31:39 UTC
Maybe. This is very open-ended however. There are dozens of things
that different distributions might want to customize, a wizard could
not hope to cover more than a couple of toy things.
Comment 4 _ tboudreau 2002-02-20 11:56:44 UTC
I'd say if we could offer the basics that get someone a reasonable
build of their app, that would be a start.  

Things like default menu configuration and so forth...it's open-ended,
but I think we could come up with a reasonable subset that would work
and be valuable.
Comment 5 Jesse Glick 2005-08-27 14:20:49 UTC
Implemented in some form. Open separate RFEs for more specific things.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo