Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 147355 - PaletteTopComponent$ResolvableHelper is loaded during 2nd NetBeans startup
PaletteTopComponent$ResolvableHelper is loaded during 2nd NetBeans startup
Status: VERIFIED FIXED
Product: platform
Classification: Unclassified
Component: Palette
6.x
All All
: P3 (vote)
: 6.x
Assigned To: Stanislav Aubrecht
issues@platform
: PERFORMANCE, TEST
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-16 11:30 UTC by Alexander Kouznetsov
Modified: 2008-12-22 14:57 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
Stacktrace (3.32 KB, text/plain)
2008-09-16 11:31 UTC, Alexander Kouznetsov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alexander Kouznetsov 2008-09-16 11:30:01 UTC
Performance test reports that the following class is loaded during 2nd NetBeans startup.

org.netbeans.spi.palette.PaletteTopComponent$ResolvableHelper

Please don't load this class.

This issue is based on the following jtulach's comment: "Similar bug as in the CND case (issue 147352). Report a bug to
core/palette and somehow tight those bugs together. Maybe the problem is in window system itself."
Comment 1 Alexander Kouznetsov 2008-09-16 11:31:03 UTC
Created attachment 69932 [details]
Stacktrace
Comment 2 Stanislav Aubrecht 2008-09-17 15:07:32 UTC
fixed

52d84c7ac1e4
Comment 3 Quality Engineering 2008-09-18 05:30:33 UTC
Integrated into 'main-golden', will be available in build *200809180201* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/52d84c7ac1e4
User: S. Aubrecht <saubrecht@netbeans.org>
Log: #147355 - PaletteTopComponent$ResolvableHelper is loaded during 2nd NetBeans startup
Comment 4 Alexander Kouznetsov 2008-09-30 16:02:44 UTC
Verified with 080929


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo