Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 146601 - should all 'Go to' actions in Navigate menu be aggregated into its own submenu?
should all 'Go to' actions in Navigate menu be aggregated into its own submenu?
Status: RESOLVED DUPLICATE of bug 148052
Product: ide
Classification: Unclassified
Component: UI
6.x
All All
: P3 (vote)
: TBD
Assigned To: Ondrej Langr
issues@ide
issue_reviewed
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-09 02:50 UTC by David Konecny
Modified: 2009-12-07 06:04 UTC (History)
0 users

See Also:
Issue Type: ENHANCEMENT
:


Attachments
Goto actions (31.85 KB, image/png)
2008-09-09 02:51 UTC, David Konecny
Details

Note You need to log in before you can comment on or make changes to this bug.
Description David Konecny 2008-09-09 02:50:38 UTC
That is instead of 9 separate 'Go to ...' actions in Navigate menu have just one 'Go to' action with submenu containing
all the actions. Disadvantage would be the impact on quick accessibility of actions - one more menu to go through. But
as it is now (look at the screenshot) it is little bit bloated.
Comment 1 David Konecny 2008-09-09 02:51:15 UTC
Created attachment 69369 [details]
Goto actions
Comment 2 jrojcek 2008-09-09 10:53:47 UTC
Yes, the Full IDE is even worse.  Instead of pushing actions into a submenu (which is certainly a solution), I would suggest to try merging some of the items. 
For example Go to File, Type, Symbol and Spring Bean is the same feature. The user needs to type a few characters and then choose from the search results.

Also various Go to Test, Action/View, Controller, and similar action may share a common UI. Maybe.
Comment 3 David Konecny 2008-09-09 22:41:13 UTC
Merging sounds like a good approach to try.

Who actually owns task like this? Is it UI/HIE team who drive this? Because it is functionality cross several modules
which individual module owners tend to ignore. Recently I played with IDE from user's point of view and there are some
inconsistencies or "implementation/architecture" leaks. Perhaps the IDE needs another Out-of-Box Experience study? Do
you, Jano, plan to do something like that or have resources for that? I think it would be good theme for next release.
Comment 4 jrojcek 2008-09-23 12:47:49 UTC
In theory, tasks like this should be driven by HIEs. The first step should be filing it as a PLAN issue so that it's considered during the planning phase for the 
next release.
Comment 5 Ondrej Langr 2009-04-08 12:05:34 UTC
Taking ownership, jrojcek no longer works on NetBeans. 
Comment 6 Ondrej Langr 2009-12-07 06:04:31 UTC
I'm coming to a conclusion that better way is to integrate these actions together, rather than just grouping them into a submenu. In a submenu containing many of these actions, it'll still be difficult to understand which action to use for given goal. 

Marking as duplicate of issue which requests to integrate "Go To" actions.

*** This bug has been marked as a duplicate of bug 148052 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo