Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 146306 - Rename does not work for event handler parameters.
Rename does not work for event handler parameters.
Status: RESOLVED DUPLICATE of bug 106831
Product: guibuilder
Classification: Unclassified
Component: Code
5.x
All All
: P3 (vote)
: TBD
Assigned To: issues@guibuilder
issues@guibuilder
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-09-05 11:48 UTC by Jan Jancura
Modified: 2008-09-08 13:49 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jan Jancura 2008-09-05 11:48:31 UTC
1) Create some form (JFrame)
2) add JButton there
3) Generate add actionPerformed(java.awt.event.ActionEvent evt) {} event handler there (popup menu on JButton > Events >
Actions...)
4) write System.out.println (evt);
5) try to rename evt variable (Ctrl-R)
> second usage of evt variable is renamed only.
Code is broken...
Comment 1 Jan Stola 2008-09-08 13:49:09 UTC
This is one of known limitations of refactoring support in GUI builder. See issue 106831 and section Rename event 
handler parameter' in http://wiki.netbeans.org/GUIBuilderRefactoring

*** This issue has been marked as a duplicate of 106831 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo